bit-tech.net

Archive for the ‘epic fail’ tag

Epic Fail: ECS X58B-A motherboard

Posted on 30th Jan 2009 at 11:05 by Richard Swinburne with 4 comments

We've tried and tried and tried over the last few months to get this motherboard to work, and eventually we sometimes just have to call it a day. And that's often one of the hardest things to accept because we've ploughed so much time into it.

One of the benefits of our new blog is that there's now a medium for us to forewarn you about those products that come into our labs but don't make it through the review process after many, many man hours trying - for example, this board has been on and off the test bench for nearly three months now. It gives us a chance to name and shame products that really don't meet the grade at all - we hope it won't happen too often but you never know... this could become more regular than we'd expect.

Epic Fail: ECS X58B-A motherboard Hardware Fail #1: ECS X58B-A Motherboard

To cut a long story short, our first board was sent back to ECS in Taiwan after our initial failed attempts to get it working. The company claimed it was faulty and sent another they guaranteed as working - it even came with a nice "It works!" sticker on the box.

Read more

Assassin's Creed: Unity Review

Assassin's Creed: Unity Review

Ubisoft's latest historical hitman game is less of a coup-de-grace and...
Mod of the Month October 2014 in association with Corsair

Mod of the Month October 2014 in association with Corsair

Six up and coming modding projects straight from our forum

Browse articles by company