




<!DOCTYPE html>
<html lang="en">
<head>
    <!-- Global site tag (gtag.js) - Google Analytics -->
    <script async src="https://www.googletagmanager.com/gtag/js?id=UA-133454118-1"></script>

    <meta charset="UTF-8">
    
        <meta http-equiv="Content-Security-Policy" content="upgrade-insecure-requests">
    
    
    <meta name="google-site-verification" content="pJDxlXLu6qkw0N9XOkomADfapzn2GZYpsclOOyyMwxw" />
    <link rel="preconnect" href="https://serve.themediateam.net" crossorigin>
    <link rel="preconnect" href="https://www.google.com" crossorigin>
    <link rel='preconnect' href='https://www.gstatic.com' crossorigin>
    <link rel='preconnect' href='https://www.youtube.com' crossorigin>
    
    <!-- <script src="/static/external/js/jquery-1.12.3.min.js"></script> -->
    <script src="https://ajax.googleapis.com/ajax/libs/jquery/1.12.3/jquery.min.js"></script>
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
    <meta name="keywords" content="
        
            Jedi Academy,
        
            Jedi: Fallen Order,
        
            Jedi Knight,
        
            Jedi Outcast,
        
            Star Wars
        
    " />
    <!-- RSS FEEDS -->
    <link rel="alternate" href="/xml/all.rss" type="application/rss+xml" charset="utf-8" title="bit-tech feed" />
    <link rel="alternate" href="/xml/bittech.rss" type="application/rss+xml" charset="utf-8" title="Article feed" />
    <link rel="alternate" href="/xml/news.rss" type="application/rss+xml" charset="utf-8" title="News feed" />
    <link rel="alternate" href="/xml/hardware.rss" type="application/rss+xml" charset="utf-8" title="Hardware feed" />
    <link rel="alternate" href="/xml/gaming.rss" type="application/rss+xml" charset="utf-8" title="Gaming feed" />
    <link rel="alternate" href="/xml/modding.rss" type="application/rss+xml" charset="utf-8" title="Modding feed" />
    <link rel="alternate" href="/xml/blog.rss" type="application/rss+xml" charset="utf-8" title="Blog feed" />
    <link rel="alternate" href="/xml/blog/podcasts.rss" type="application/rss+xml" charset="utf-8" title="Podcasts feed" />
    <link rel="alternate" href="/xml/bits.rss" type="application/rss+xml" charset="utf-8" title="Bits feed" />
    <link href="https://fonts.googleapis.com/css?family=Open+Sans" rel="stylesheet">
    <link href="https://maxcdn.bootstrapcdn.com/font-awesome/4.4.0/css/font-awesome.min.css" rel="stylesheets">
    <link href="https://maxcdn.bootstrapcdn.com/font-awesome/4.4.0/css/font-awesome.min.css" rel="stylesheet">
    <!-- <link href="https://fonts.googleapis.com/css?family=Roboto" rel="stylesheet"> -->

    <link rel="canonical" href="https://bit-tech.net/reviews/gaming/pc/star-wars-jedi-fallen-order-review/1/" />
    <meta name="theme-color" content="#3f2856">

    <!-- OLD STYLES -->
    <link rel="apple-touch-icon" href="//images.bit-tech.net/images/webclip.png" />
    
    
    <!-- NEW STYLES -->
    <link rel="shortcut icon" href="/static/public/image/favicon.ico" />
    <style>
        *, *:after, *:before {
            -webkit-box-sizing: border-box;
            -moz-box-sizing: border-box;
            box-sizing: border-box;
        }
        body {
            margin: 0;
        }
        [class*='col-'] {
            float: left;
            min-height: 1px;
        }
        .col-1-1 {
            width: 100%;
        }
        .col-3-12 {
            width: 25%;
        }
        .col-6-12 {
            width: 50%;
        }
        .col-1-3 {
            width: 33.33%;
        }
        .col-1-4 {
            width: 25%;
        }
        .col-1-8 {
            width: 12.5%;
        }
        .col-9-12 {
            width: 75%;
        }
    </style>
    <link rel="stylesheet"  href="/static/public/css/main.v2.css" />
    <link rel="stylesheet" href="/static/cms_surveys/css/base_v2.css">
    
    <style>
        @font-face {
            font-family: 'FontAwesome';
            src: url('/static/external/css/font-awesome-4.6.3/fonts/fontawesome-webfont.eot?v=4.6.3');
            src: url('/static/external/css/font-awesome-4.6.3/fonts/fontawesome-webfont.eot?#iefix&v=4.6.3') format('embedded-opentype'), url('/static/external/css/font-awesome-4.6.3/fonts/fontawesome-webfont.woff2?v=4.6.3') format('woff2'), url('/static/external/css/font-awesome-4.6.3/fonts/fontawesome-webfont.woff?v=4.6.3') format('woff'), url('/static/external/css/font-awesome-4.6.3/fonts/fontawesome-webfont.ttf?v=4.6.3') format('truetype'), url('/static/external/css/font-awesome-4.6.3/fonts/fontawesome-webfont.svg?v=4.6.3#fontawesomeregular') format('svg');
            font-weight: normal;
            font-style: normal;
        }
        .fa {
            display: inline-block;
            font: normal normal normal 14px/1 FontAwesome;
            font-size: inherit;
            text-rendering: auto;
            -webkit-font-smoothing: antialiased;
            -moz-osx-font-smoothing: grayscale
        }
        .fa-home:before {
            content: "\f015";
        }
        .fa-envelope:before {
            content: "\f0e0";
        }
        .fa-comments:before {
            content: "\f086";
        }
    </style>
    
        <link rel="stylesheet"  href="/static/public/css/section/reviews.css" />
    
    
        <link rel="stylesheet"  href="/static/public/css/category/gaming.css" />
    
    <style>
        body{
            margin:0;
            background:#000 url("/static/public/image/bittech_18_bg.jpg") fixed no-repeat 50% 0;
        }
        #side_column{
            float:right;
        }
        #blurBackground{
            margin: 0;
            background: #000 url("/static/public/image/bittech_18_bg.jpg") fixed no-repeat 50% 0;
        }
        #blurBackground.blurred{
            filter: blur(4px);
            -webkit-filter: blur(4px);
            filter: blur(4px);
            -o-filter: blur(4px);
            -ms-filter: blur(4px);
            -moz-filter: blur(4px);
        }
        #skin {
            position: absolute;
            left: 0px;
            top: 0px;
            right: 0px;
            bottom: 0px;
            width: 100%;
        }
        #skin > #skinclick {
            display: block;
            width: 100%;
            height: 100%;
        }
        body .pageContainer {
            z-index: 999;
            background: white;
        }
        #skin {
            position: absolute;
            left: 0px;
            top: 0px;
            right: 0px;
            bottom: 0px;
            width: 100%;
        }
        #skin > #skinclick {
            display: block;
            width: 100%;
            height: 100%;
        }
        body .pageContainer {
            z-index: 9999;
            background: white;
        }
    </style>
    <script type="text/javascript">
        document.cutoff = 980;
    </script>
    
    
    
        
        <link rel="stylesheet"  href="/static/public/css/detail.v2.css" />
        <link rel="stylesheet" href="/static/public/css/legacy_graphs.css" />
        <link rel="stylesheet" href="/static/public/css/legacy.css" defer/>
        <!-- sharethis buttons -->
        <script type='text/javascript' src='//platform-api.sharethis.com/js/sharethis.js#property=594b47e099baea0012f9c055&product=inline-share-buttons' async='async'></script>    
        <link rel="stylesheet"  href="/static/public/css/external/icons.css" defer/>
        

<!-- for google -->

<title>Star Wars: Jedi: Fallen Order Review | bit-tech.net</title>
<meta name="description" content="Is Respawn&#39;s Star Wars game a return to the glory days of Jedi Knight or more of a Holiday Special?" />
<meta name="robots" content="index, follow" />
<meta name="googlebot" content="index, follow" />
<meta charset="utf-8">
<!-- for facebook -->

<meta property="og:url" content="https://bit-tech.net/reviews/gaming/pc/star-wars-jedi-fallen-order-review/1/" />
<meta property="og:title" content="Star Wars: Jedi: Fallen Order Review | bit-tech.net" />
<meta property="og:description" content="Is Respawn&#39;s Star Wars game a return to the glory days of Jedi Knight or more of a Holiday Special?" />
<meta property="og:image" content="https://bit-tech.net/media/image/2019/11/04959c9e-8468-46bb-b0f0-bfa00c5cf034.jpeg" />
<meta property="fb:app_id" content="1859842647618090"/>

    <meta property="og:type" content="article" />


    <meta property="og:locale" content="en_GB" />

<!-- for twitter -->

<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@bittech" />
<meta name="twitter:creator" content="@bittech" />
<meta name="twitter:title" content="Star Wars: Jedi: Fallen Order Review | bit-tech.net">
<meta name="twitter:description" content="Is Respawn&#39;s Star Wars game a return to the glory days of Jedi Knight or more of a Holiday Special?" />
<meta name="twitter:image" content="https://bit-tech.net/media/image/2019/11/04959c9e-8468-46bb-b0f0-bfa00c5cf034.jpeg" />

<!-- Schema.org markup for Google+ -->
<meta itemprop="name" content="Star Wars: Jedi: Fallen Order Review | bit-tech.net">
<meta itemprop="description" content="Is Respawn&#39;s Star Wars game a return to the glory days of Jedi Knight or more of a Holiday Special?">
<meta itemprop="image" content="https://bit-tech.net/media/image/2019/11/04959c9e-8468-46bb-b0f0-bfa00c5cf034.jpeg">
<!-- for amazon -->

    <link rel="search" type="application/opensearchdescription+xml" href="/opensearch_xml/" title="https://bit-tech.net search" />

<!-- more on meta tags and SEO -->



        
            <!-- JSON-LD markup -->
            <script type="application/ld+json">
                {
                    "@context" : "http://schema.org",
                    "@type" : "Review",
                    "headline" : "Star Wars: Jedi: Fallen Order Review",
                    "url" : "https://bit-tech.net/reviews/gaming/pc/star-wars-jedi-fallen-order-review/1/",
                    "inLanguage":"en",
                    "discussionUrl" : "https://forums.bit-tech.net/index.php?threads/369464",
                    "image": "https://bit-tech.net/media/image/2019/11/04959c9e-8468-46bb-b0f0-bfa00c5cf034.jpeg",
                    "datePublished" : "2019-11-21T13:00:00+00:00",
                    "dateModified" : "2019-11-21T13:00:00+00:00",
                    "description" : "Is Respawn&#39;s Star Wars game a return to the glory days of Jedi Knight or more of a Holiday Special?",
                    "author" : {
                        "@type" : "Person",
                        "name" : "Rick Lane"
                    },
                    "itemReviewed" : {
                        "@type" : "Thing",
                        "name" : "Star Wars: Jedi: Fallen Order Review"
                    },
                    "mainEntityOfPage": {
                        "@type": "WebPage",
                        "@id": "https://bit-tech.net/reviews/gaming/pc/star-wars-jedi-fallen-order-review/1/"
                    },
                    "publisher": {
                        "@type": "Organization",
                        "name": "bit-tech",
                        "url" : "https://bit-tech.net/",
                        "sameAs": [
                            "https://www.facebook.com/bittech",
                            "https://twitter.com/bittech",
                            "https://www.instagram.com/bit_tech/",
                            "https://www.youtube.com/channel/UCGxtYMx16kD7jK0RKSxsVrw"
                        ],
                        "logo": {
                            "@type": "ImageObject",
                            "url": "https://www.themediateam.net/static/img/resources/bit-tech/bit-tech.png"
                        }
                    }
                }
            </script>
        
    
    
    <!-- JSON-LD markup -->
    <script type="application/ld+json">
        {
            "@context": "http://schema.org",
            "@type": "Organization",
            "name": "bit-tech",
            "url" : "https://bit-tech.net/",
            "sameAs": [
                "https://www.facebook.com/bittech",
                "https://twitter.com/bittech",
                "https://www.instagram.com/bit_tech/",
                "https://www.youtube.com/channel/UCGxtYMx16kD7jK0RKSxsVrw"
            ],
            "logo": {
                "@type": "ImageObject",
                "url": "https://www.themediateam.net/static/img/resources/bit-tech/bit-tech.png"
            }
        }
    </script>
    <script>
        (function (w, d, t) {
            _ml = w._ml || {};
            _ml.eid = '62979';
            var s, cd, tag; s = d.getElementsByTagName(t)[0]; cd = new Date();
            tag = d.createElement(t); tag.async = 1;
            tag.src = 'https://ml314.com/tag.aspx?' + cd.getDate() + cd.getMonth();
            s.parentNode.insertBefore(tag, s);
        })(window, document, 'script');
    </script>
    <script>
        window.dataLayer = window.dataLayer || [];
        function gtag(){dataLayer.push(arguments);}
        gtag('js', new Date());
        
        gtag('config', 'UA-133454118-1');
    </script>
</head>
<body>

<!-- Style Switcher -->
<input id="settings-btn" type="checkbox" class="settings-btn">
<label for="settings-btn" class="settings-box-element"><i class="fa fa-chevron-left"></i></label>
<!-- the white box that contains the buttons -->
<div class="buttons-wrapper settings-box-element"></div>

<!-- Style Switcher Themes -->

<!-- dark background -->
<input id="dark-layout" class="dark-layout" type="radio" name="layout">
<label for="dark-layout" class="layout-buttons settings-box-element">Dark Theme</label>
<!-- light background -->
<input id="light-layout" class="light-layout" type="radio" name="layout" checked>
<label for="light-layout" class="layout-buttons settings-box-element">Light Theme</label>
<!-- ./Style Switcher -->

<div id="blurBackground">
    <a name="top" id="top"></a>
    <div class="pageContainer">
        <div id="brandHeader" class="clearfix">
            
                <a href="/category/gaming/"><img class="logo" src="/static/public/image/bit_gamer_logo.png" alt="bit-gamer"></a>
            
            <div class="xtag-153">
                <script type='text/javascript'><!--//<![CDATA[
   var m3_u = (location.protocol=='https:'?'https://serve.themediateam.net/ox/www/delivery/ajs.php':'https://serve.themediateam.net/ox/www/delivery/ajs.php');
   var m3_r = Math.floor(Math.random()*99999999999);
   if (!document.MAX_used) document.MAX_used = ',';
   document.write ("<scr"+"ipt type='text/javascript' src='"+m3_u);
   document.write ("?zoneid=153&amp;source=_blank&amp;target=_blank");
   document.write ('&amp;cb=' + m3_r);
   if (document.MAX_used != ',') document.write ("&amp;exclude=" + document.MAX_used);
   document.write (document.charset ? '&amp;charset='+document.charset : (document.characterSet ? '&amp;charset='+document.characterSet : ''));
   document.write ("&amp;loc=" + escape(window.location));
   if (document.referrer) document.write ("&amp;referer=" + escape(document.referrer));
   if (document.context) document.write ("&context=" + escape(document.context));
   if (document.mmm_fo) document.write ("&amp;mmm_fo=1");
   document.write ("'><\/scr"+"ipt>");
//]]>--></script><noscript><a href='https://serve.themediateam.net/ox/www/delivery/ck.php?n=a35f64acc&amp;cb=INSERT_RANDOM_NUMBER_HERE' target='_blank'><img src='https://serve.themediateam.net/ox/www/delivery/avw.php?zoneid=153&amp;source=_blank&amp;cb=INSERT_RANDOM_NUMBER_HERE&amp;n=a35f64ac' border='0' alt='' /></a></noscript>

            </div>
        </div>
        
            <div id="navContainer" class="clearfix">
                <div id="mainNav" class="clearfix">
                    
                    <ul id="topList" class="clearfix">
                        <a href="/">
                            <li id="topListHome" class="topLi " >
                                <div class="topLi-icon fa fa-home" style="display:none;"></div>
                                <img src="/static/public/image/icons/home-icon.svg" alt="bit-tech home page">
                                <span>Home</span>
                            </li>
                        </a>
                        
                            <a href="/category/tech/">
                                <li data-section="tech" class="topLi " >
                                    <div class="topLi-icon" style="display:none;"></div>
                                    <span>Tech</span>
                                </li>
                            </a>
                        
                            <a href="/category/modding/">
                                <li data-section="modding" class="topLi " >
                                    <div class="topLi-icon" style="display:none;"></div>
                                    <span>Modding</span>
                                </li>
                            </a>
                        
                            <a href="/category/gaming/">
                                <li data-section="gaming" class="topLi active" >
                                    <div class="topLi-icon" style="display:none;"></div>
                                    <span>Gaming</span>
                                </li>
                            </a>
                        
                        <a href="//forums.bit-tech.net">
                            <li id="topListForum" >
                                <div class="topLi-icon fa fa-comments" style="display:none;"></div>
                                <span>Forum</span>
                            </li>
                        </a>
                    </ul>
                    <div class="right_box">
                        <div class="icons">
                            <a href="https://www.facebook.com/bittech">
                                <img src="/static/public/image/icons/facebook.svg" alt="bit-tech Facebook page">
                            </a>
                            <a href="https://www.twitter.com/bittech">
                                <img src="/static/public/image/icons/twitter.svg" alt="bit-tech Twitter feed">
                            </a>
                            <a href="https://www.instagram.com/bit_tech/">
                                <img src="/static/public/image/icons/instagram.svg" alt="bit-tech Instagram feed">
                            </a>
                            <a href="https://www.youtube.com/c/bittech1">
                                <img src="/static/public/image/icons/youtube.svg" alt="bit-tech YouTube channel">
                            </a>
                            <a href="https://discord.gg/EBGNWYm">
                                <img src="/static/public/image/icons/discord.svg" alt="bit-tech discord channel">
                            </a>
                            <a href="/rss/">
                                <img src="/static/public/image/icons/rss.svg" alt="bit-tech RSS feed">
                            </a>
                        </div>
                    </div>
                    
                    <div class="account-options">
                        
                        
                            <a id="accounts_icon" href="/login/">
                                <span class="account-option">Login</span>
                            </a>
                            <a href="/register/">
                                <span class="account-option">Register</span>
                            </a>
                        
                        
                    </div>
                </div>
                
                <div id="subNav" class="clearfix">
                    <ul id="secondList" style="display: inline-flex; max-width: initial; width: initial;">
                        <li >
                            
                                <a href="/category/gaming/">
                            
                                <span>All</span>
                            </a>
                        </li>
                        
                            <li class="" >
                                
                                    
                                        <a href="/news/gaming/">
                                    
                                        <span>News</span>
                                    </a>
                                
                            </li>
                        
                            <li class="active" >
                                
                                    
                                        <a href="/reviews/gaming/">
                                    
                                        <span>Reviews</span>
                                    </a>
                                
                            </li>
                        
                            <li class="" >
                                
                                    
                                        <a href="/features/gaming/">
                                    
                                        <span>Features</span>
                                    </a>
                                
                            </li>
                        
                            <li class="" >
                                
                                    
                                        <a href="/previews/gaming/">
                                    
                                        <span>Previews</span>
                                    </a>
                                
                            </li>
                        
                            <li class="" >
                                
                                    
                                        <a href="/guides/gaming/">
                                    
                                        <span>Guides</span>
                                    </a>
                                
                            </li>
                        
                            <li class="" >
                                
                                    
                                        <a href="/blogs/gaming/">
                                    
                                        <span>Blogs</span>
                                    </a>
                                
                            </li>
                        
                            <li class="" >
                                
                                    
                                        <a href="/competitions/gaming/">
                                    
                                        <span>Competitions</span>
                                    </a>
                                
                            </li>
                        
                            <li class="" >
                                
                                    <a href="/press-releases/">
                                        <span>Press Releases</span>
                                    </a>
                                
                            </li>
                        
                    </ul>
                    <div class="search">
                        <form id="search_form" action="/search/" method="get" accept-charset="utf-8">
                            <input type="text" name="q" value="" placeholder="SEARCH"/>
                            <span class="button">
                                <input type="submit" value="">
                            </span>
                        </form>
                    </div>
                </div>
                
                    <div id="anotherSubNav" class="clearfix">
                        <ul id="thirdList" style="display: inline-flex; max-width: initial; width: initial;">
                            <li class="active">
                                
                                    <a href="/reviews/gaming/">
                                
                                    <span>All</span>
                                </a>
                            </li>
                            
                                
                            
                                
                            
                                
                                    
                                        <li  >
                                            <a href="
                                                /reviews/gaming/apple/
                                            ">
                                                <span>Apple</span>
                                            </a>
                                        </li>
                                    
                                        <li  >
                                            <a href="
                                                /reviews/gaming/linux/
                                            ">
                                                <span>Linux</span>
                                            </a>
                                        </li>
                                    
                                        <li  >
                                            <a href="
                                                /reviews/gaming/mobile-gaming/
                                            ">
                                                <span>Mobile Gaming</span>
                                            </a>
                                        </li>
                                    
                                        <li  >
                                            <a href="
                                                /reviews/gaming/nintendo/
                                            ">
                                                <span>Nintendo</span>
                                            </a>
                                        </li>
                                    
                                        <li  >
                                            <a href="
                                                /reviews/gaming/pc/
                                            ">
                                                <span>PC</span>
                                            </a>
                                        </li>
                                    
                                        <li  >
                                            <a href="
                                                /reviews/gaming/playstation/
                                            ">
                                                <span>Playstation</span>
                                            </a>
                                        </li>
                                    
                                        <li  >
                                            <a href="
                                                /reviews/gaming/retro/
                                            ">
                                                <span>Retro</span>
                                            </a>
                                        </li>
                                    
                                        <li  >
                                            <a href="
                                                /reviews/gaming/virtual-reality/
                                            ">
                                                <span>Virtual Reality</span>
                                            </a>
                                        </li>
                                    
                                        <li  >
                                            <a href="
                                                /reviews/gaming/xbox/
                                            ">
                                                <span>Xbox</span>
                                            </a>
                                        </li>
                                    
                                
                            
                        </ul>
                    </div>
                
                
            </div>
        
        <div class="xtag-173">
            <script type='text/javascript'><!--//<![CDATA[
   var m3_u = (location.protocol=='https:'?'https://serve.themediateam.net/ox/www/delivery/ajs.php':'https://serve.themediateam.net/ox/www/delivery/ajs.php');
   var m3_r = Math.floor(Math.random()*99999999999);
   if (!document.MAX_used) document.MAX_used = ',';
   document.write ("<scr"+"ipt type='text/javascript' src='"+m3_u);
   document.write ("?zoneid=173&amp;source=_blank&amp;target=_blank");
   document.write ('&amp;cb=' + m3_r);
   if (document.MAX_used != ',') document.write ("&amp;exclude=" + document.MAX_used);
   document.write (document.charset ? '&amp;charset='+document.charset : (document.characterSet ? '&amp;charset='+document.characterSet : ''));
   document.write ("&amp;loc=" + escape(window.location));
   if (document.referrer) document.write ("&amp;referer=" + escape(document.referrer));
   if (document.context) document.write ("&context=" + escape(document.context));
   if (document.mmm_fo) document.write ("&amp;mmm_fo=1");
   document.write ("'><\/scr"+"ipt>");
//]]>--></script><noscript><a href='https://serve.themediateam.net/ox/www/delivery/ck.php?n=a35f64abc&amp;cb=INSERT_RANDOM_NUMBER_HERE' target='_blank'><img src='https://serve.themediateam.net/ox/www/delivery/avw.php?zoneid=173&amp;source=_blank&amp;cb=INSERT_RANDOM_NUMBER_HERE&amp;n=a35f64ab' border='0' alt='' /></a></noscript>

        </div>
        <div id="bodyContainer" class="clearfix">
            <div class="clearfix" style="clear:both;">
                <div id="main_column">
                    
    
    
    
        
            

<link rel="stylesheet" type="text/css" href="/static/public/modal/baguetteBox.css">
<style>
    .image-source-link {
        color: #98C3D1;
    }

    .mfp-with-zoom .mfp-container,
    .mfp-with-zoom.mfp-bg {
        opacity: 0;
        -webkit-backface-visibility: hidden;
        /* ideally, transition speed should match zoom duration */
        -webkit-transition: all 0.3s ease-out; 
        -moz-transition: all 0.3s ease-out; 
        -o-transition: all 0.3s ease-out; 
        transition: all 0.3s ease-out;
    }

    .mfp-with-zoom.mfp-ready .mfp-container {
            opacity: 1;
    }
    .mfp-with-zoom.mfp-ready.mfp-bg {
            opacity: 0.8;
    }

    .mfp-with-zoom.mfp-removing .mfp-container, 
    .mfp-with-zoom.mfp-removing.mfp-bg {
        opacity: 0;
    }
</style>
<div class="articleCopy">
    <div id="article-top">
        <div id="article-details">
            <div class="object_headings" style="flex-grow: 1;">
                <h1 class="heading" >Star Wars: Jedi: Fallen Order Review</h1>
                <div class="clearfix">
                    <p class="author" >Written by
                        <a href="/author/rick-lane/">
                            Rick Lane
                        </a>
                    </p>
                    <div class="sharethis-inline-share-buttons" ></div>
                </div>
                <p class="datetime" >November 21, 2019 | 13:00</p>
                
                    
                        <p class="tags" >Tags: <a href="/tag/jedi-academy/">#jedi-academy</a> <a href="/tag/jedi-fallen-order/">#jedi-fallen-order</a> <a href="/tag/jedi-knight/">#jedi-knight</a> <a href="/tag/jedi-outcast/">#jedi-outcast</a> <a href="/tag/star-wars/">#star-wars</a> </p>
                    
                
                 
                    
                        <p class="companies">Companies: <a href="/company/ea/">#ea</a> <a href="/company/respawn-entertainment/">#respawn-entertainment</a> </p>
                    
                
                
            </div>
            
                
            
        </div>
        <div id="top_thumbnail" class="clearfix" >
            
            
                
                    <img src="/media/image/2019/11/04959c9e-8468-46bb-b0f0-bfa00c5cf034.jpeg" alt="">
                
            
        </div>
    </div>
    <div id="page_body" class="object_body">
            
        <p><p><strong>Price:</strong> £54.99</p><p><strong>Developer:</strong> Respawn Entertainment</p><p><strong>Publisher:</strong> EA</p><p><strong>Platform(s):</strong> PC, PS4, Xbox One</p><p><strong>Version reviewed: </strong>PC</p><p>EA’s handling of the Star Wars license has been, quite frankly, dreadful. Since acquiring the exclusive rights to publish Star Wars games in 2013, EA has published exactly two major Star Wars titles, both of which were Battlefront, both of which had serious problems. But this year, a new hope has arisen. A single-player, Jedi-focussed action-adventure developed by one of this year’s hottest developers, Respawn Entertainment. Could this be the game that finally breaks the long, long Star Wars duck, a spiritual successor to LucasArts’ splendid Jedi Knight games of the late nineties and early noughties?</p><p><img draggable="false" class="img-responsive" data-original="" src="//www.bit-tech.net/media/image/2019/11/fb747066-d52b-4a9e-97c7-960e5752f610.jpg" id="9gsy52"></p><p>Nope.</p><p>Let’s be clear: Fallen Order has potential. The combat is well designed (if still inferior to Raven’s Jedi Knight games) and there are moments within its long campaign that glitter with Star Wars magic. But it’s also a very confused design, mixing bits of Uncharted, Mass Effect, and even Dark Souls in ways that just about hangs together but don't improve the game over those individual experiences. It also has a strong whiff of not being finished, with wild variances in visual quality and some obvious holes in the canvas.</p><p><img draggable="false" class="img-responsive" data-original="" src="//www.bit-tech.net/media/image/2019/11/a1caaf9b-05ad-4a44-a0f4-7b12c3986ee7.jpg" id="1ks4h8"></p><p>Oh, and the story is a complete nonentity. It takes place in that 20-year gap between Episodes III and IV that Star Wars games seem to love but struggle to do much interesting with (Dark Forces being the exception). You play as Cal Kestis, a Padawan in hiding from the Empire’s Jedi purge, masquerading as a shipbreaker on a giant junkyard planet. Cal’s cover lasts all of five minutes before he’s blown out of his swamp-rat hole by the Imperial Inquisition. Rescued by another former Jedi named Cere (pronounced 'seer'), Cal then embarks on a planet-hopping quest to retrieve a Jed Holocron that contains the names of Force Sensitive children throughout the galaxy.</p><p>It’s a MacGuffin chase, basically, an excuse to get the player bouncing back and forth between six different planets. It admittedly has the odds stacked against it. Not only is it wedged in this awkward time-frame where only certain things can happen, it’s also a story about Jedi, every single one of whom has the exact same tedious story arc. Jedi discovers force. Jedi learns force. Jedi has traumatic experience. Jedi is tempted by Dark Side. Jedi either succumbs or resists temptation. Curtains.</p><p><img draggable="false" class="img-responsive" data-original="" src="//www.bit-tech.net/media/image/2019/11/1dc751c5-8c73-488d-8254-51efcfa32d32.jpg" id="ywy3w"></p><p>Nonetheless, I think Respawn could have done better. And I think that was the plan. There’s a sprinkling of Mass Effect to the way the story is told, with you gradually assembling a party of characters on your ship as you travel around the galaxy. Unfortunately the game never gets much of a chance to explore those characters. Late in the game you’re joined by a Night Sister, a non-Jedi Force user who, despite initial appearances, turns out to be a quite a fun supporting character. But by the time she joins you you’re basically at the end of the game, and she gets no opportunity to actually do anything. There’s also the bizarre vanishing act of Forest Whitaker, who appears as a seemingly significant character in the middle of the game, before never being heard from again.</p><p>Such inconsistencies aren’t limited to the story either. Visually, Fallen Order is all over the place. The opening escape from the junkyard is pure AAA spectacle. After this, however, you’re transported to the introductory planet of Bogano, which looks, well, it looks like this:</p><p><img draggable="false" class="img-responsive" data-original="" src="//www.bit-tech.net/media/image/2019/11/199371ec-cdc0-45c5-a80c-fc5339a07408.jpg" id="cxr6xn"></p><p>Ew. And it isn’t just separate planets that vary in visual quality. Kashyyyk, for example, looks brilliant in some places, rough as a wookie’s armpit in others. A big problem is that throughout the game the level design looks painfully artificial. Platforms stick out like a Twi’lek’s head-tentacles, while on every world you’ll encounter bizarre slides that Respawn attempt to disguise as glaciers on Zeffo and then basically give up on disguising at all farther down the line. I know Star Wars games generally have a surrealist quality to the level design, but at times Fallen Order resembles LEGO Uncharted.</p><p>The broader level design has problems too. I like the concept, where each level has multiple paths that take you to different places, with shortcuts gradually opening up between them. It’s clearly inspired by Dark Souls, including meditation zones that act as checkpoints which refill your health-replenishing stims, while respawning all enemies at the same time. Sadly, Fallen Order struggles to give you much reason to explore beyond the main story. The only tangible reward you get for exploring is an increase to your stim count, which is useful and worth seeking out. All remaining unlocks are cosmetic, mainly customisation elements for your lightsaber and outfit. While I was happy to explore at first, after Zeffo the level designs become far less nuanced, and I quickly lost interest in exploring off the beaten path.</p><p><img draggable="false" class="img-responsive" data-original="" src="//www.bit-tech.net/media/image/2019/11/cb0dfe6a-b38e-432a-832b-b994f555dd65.jpg" id="yujf88"></p><p>In short, Fallen Order is a bit of a mess, one that I expect was intended to be a much broader experience than how it appears in its final form. But it is rescued from total disaster by its combat. Again, Fallen Order takes strong inspiration from Dark Souls here. Even basic enemies feel dangerous, while more powerful opponents take proper effort to take down. As with the Souls games, your core skills involve attacking, blocking, dodging and rolling. Blocking at the right time will break enemy guards, giving you a window to attack, as well as deflecting laser bolts back at Stormtroopers, which is very satisfying.</p><p>It’s a slick system that, over the course of the game, reveals an impressive amount of depth. Alongside your standard attacks are your force powers - Slow, Push, and Pull - which are great for interrupting enemy attacks and, later on, for quickly dispatching weaker enemies. I particularly enjoy the pull + lightsaber stab combo, while pushing a big group of stormtroopers off a ledge never ceases to entertain. There are also a total of three lightsaber styles, including a double-bladed saber that’s useful for crowd control, and a third one that I won’t spoil. On top of this is a skill system that gradually unlocks more nuanced lightsaber techniques and force powers, such as lightsaber throws.</p><p><img draggable="false" class="img-responsive" data-original="" src="//www.bit-tech.net/media/image/2019/11/db86c8e1-13e5-4db0-959b-b147c46f5bc0.jpg" id="hs5jx"></p><p>When Cal is fully tricked out, the combat is genuinely fantastic, easily the best representation of lightsaber combat since Jedi Outcast/Jedi Academy. That being said, it still isn’t as good as either of those games for several reasons. Not only does is lack the same breadth of Force powers, but the way it represents your lightsaber’s power is inconsistent. In Jedi Outcast, for example, you could kill Stormtroopers simply by walking into them. It was always active, which made fights feel both dynamic and dangerous.</p><p>Fallen Order’s lightsaber is far more picky about when it chooses to be a lightsaber. It won’t let you cut the arms off Stormtroopers, for example, but it will let you slice entire animals in half. Which is a weird creative decision. I don’t know about you, but I’d much rather be slicing and dicing evil space nazis than random alien animals that, while aggressive, are not evil. Speaking of which, there’s far too much alien spider bashing and not enough Stormtrooper/Inquisition fighting. There are only three Jedi duels, which is unfortunate, as these are by far the best moments in the game.</p><p><img draggable="false" class="img-responsive" data-original="" src="//www.bit-tech.net/media/image/2019/11/35792fa9-fc08-4e66-8c45-5dde391c1a38.jpg" id="aky3fl"></p><p>In the end, I think Respawn would have been better off sticking to one or two ideas, rather than mixing up half a dozen in a way that stumbles forward like an AT-ST on an icy Hoth plain. It says a lot that Fallen Order’s best moments are the more hand-crafted ones. The beginning, the ending, the Jedi duels, the opening battle on Kashyyyk. These individual moments suggest Respawn could have done incredible things with a straightforward, linear adventure that placed all the focus on that combat system. But both the platforming and the open-world elements look and feel half-baked, resulting in the game that is not as strong in the Force as it perhaps deserves to be.</p><p><img draggable="false" class="img-responsive" data-original="" src="//www.bit-tech.net/media/image/2019/11/b8187ca0-6908-4386-a4cf-10f6ff26b17c.jpg" id="xprs1"></p><p><div></div></p></p><br>
    </div>
    


    
        
    

     <div id="comments_container" class="comments" style='overflow: auto;'>

        <div id="comments_action">
            
            <p class="login-link">Want to comment? Please log in.</p>
            
        </div>
        <a href="//forums.bit-tech.net/index.php?threads/369464">Discuss this in the forums</a>

        <div id="current_comments" class="clearfix" >

        </div>
        <div id="comments_nav" class="col-1-1">
            <div id="batch_numbers"></div>
        </div>
        
    </div>

    

        <div id="related_articles_container" class="clearfix">
            <h3 class="headingBar">RELATED ARTICLES</h3>
            <div id="detail-related-container">
                
                    
                        <div id="article_80201" class="article pc reviews playstation pc xbox gaming   ">
    <div class="articleinfo">
        <a href="/reviews/gaming/pc/star-wars-battlefront-ii-review/1/">
            <img src="/media/image/2019/5/39c5ff4e-d5fc-4e52-bce7-f03c4c6494a5.jpeg" alt="Star Wars: Battlefront II Review">
            <div class="article_info">
                <div class="category-dot gaming pc"></div>
                <h4 class="article_heading" >
                    Star Wars: Battlefront II Review
                </h4>
                <div class="summery clearfix">
                    <p>Star Wars: Battlefront II takes two steps forward and two steps back.</p>
                    <span class="published" >November 21, 2017 | 12:30</span>
                </div>
            </div>
        </a>
        <span class="bottom-right">
            <a href="//forums.bit-tech.net/index.php?threads/335579" class="comments">6</a>
        </span>
    </div>
    <div class="rightseparator"></div>
    <div class="bottomseparator"></div>
</div>
                    
                
                    
                        <div id="article_80180" class="article gaming news gaming   ">
    <div class="articleinfo">
        <a href="/news/gaming/ea-temporarly-removes-microtransactions-from-star-wars-battlefront-ii/1/">
            <img src="/media/image/2019/5/0f6c7107-5e61-44aa-8d31-f595878e510e.jpeg" alt="EA temporarily removes microtransactions from Star Wars Battlefront II">
            <div class="article_info">
                <div class="category-dot None gaming"></div>
                <h4 class="article_heading" >
                    EA temporarily removes microtransactions from Star Wars Battlefront II
                </h4>
                <div class="summery clearfix">
                    <p>&quot;Temporarily&quot;, mark you.</p>
                    <span class="published" >November 17, 2017 | 11:23</span>
                </div>
            </div>
        </a>
        <span class="bottom-right">
            <a href="//forums.bit-tech.net/index.php?threads/335369" class="comments">13</a>
        </span>
    </div>
    <div class="rightseparator"></div>
    <div class="bottomseparator"></div>
</div>
                    
                
                    
                        <div id="article_80066" class="article gaming news gaming   ">
    <div class="articleinfo">
        <a href="/news/gaming/ea-closes-visceral-games-pivots-upcoming-star-wars-title/1/">
            <img src="/media/image/2019/5/c5d0b11c-7f34-47a0-996a-d4d6fc64c75a.jpeg" alt="EA closes Visceral Games, pivots upcoming Star Wars title">
            <div class="article_info">
                <div class="category-dot None gaming"></div>
                <h4 class="article_heading" >
                    EA closes Visceral Games, pivots upcoming Star Wars title
                </h4>
                <div class="summery clearfix">
                    <p>No word on the number of jobs affected.</p>
                    <span class="published" >October 18, 2017 | 10:00</span>
                </div>
            </div>
        </a>
        <span class="bottom-right">
            <a href="//forums.bit-tech.net/index.php?threads/333785" class="comments">3</a>
        </span>
    </div>
    <div class="rightseparator"></div>
    <div class="bottomseparator"></div>
</div>
                    
                
            </div>
        </div>

    

    

        

    
</div>


<script src="/static/public/modal/baguetteBox.js"> </script>
<script>
    
    function resizeImages() {    
        images = document.querySelectorAll('#page_body img');
        for (let index = 0; index < images.length; index++) {
            image = images[index];
            // if (image.width == 430) {
            //     image.parentNode.width = 430;
            //     image.style.marginRight = "20px";
            // }
            if (image.width == 300) {
                console.log(image.parentElement)
                image.parentElement.width = 430;
                image.parentElement.style.width = "49%";
                image.width = 430;
                image.style.marginRight = "20px";
            }
        }
    }
    // window.onload = resizeImages()

    // setTimeout(resizeImages, 5000);


    
    elems = document.querySelectorAll('#page_body table')
    if (elems) {
        for (let index = 0; index < elems.length; index++) {
            elems[index].style = '';
        }
    }
    elems = document.querySelectorAll('#page_body table *')
    if (elems) {
        for (let index = 0; index < elems.length; index++) {
            elems[index].style = '';
        }
    }
    // elems.forEach( function(element) {
    //     element.style = ''
    // });
    
    window.onload = function() {
        ad = document.querySelector('div.footerContainer div.xtag_container')
        related = document.querySelector('#related_articles_container')
        related.before(ad);
        resizeImages()
    };
</script>

        
    



                </div>
                <div id="side_column" class="grid_6">
                    
                    <div id="banners">
                        <div style="margin-bottom:15px;">
                            <a href="https://bit-tech.net/competitions/tech/eu-competition-win-a-fractal-design-prize-bundle/1/">
                                <img src="/static/public/image/sidebar_banners/fractal-bundle-2019.jpg" alt="fractal competition" style="height:110px;">
                            </a>
                        </div>
                        <div class="side_bar_banners" >
                            <a href="//forums.bit-tech.net/index.php?forums/project-logs.42/">
                                <img src="/static/public/image/sidebar_banners/project_logs.jpg" alt="Project logs">
                            </a>
                        </div>
                        <div class="side_bar_banners" >
                            <a href="/category/modding/">
                                <img src="/static/public/image/sidebar_banners/modding.jpg" alt="modding content">
                            </a>
                        </div>
                        <div class="side_bar_banners" >
                            <a href="https://www.corsair.com/uk/en/">
                                <img src="/static/public/image/sidebar_banners/corsair.jpg" alt="Corsair">
                            </a>
                        </div>
                    </div>
                    
                    <div class="xtag-157">
                        <script type='text/javascript'><!--//<![CDATA[
   var m3_u = (location.protocol=='https:'?'https://serve.themediateam.net/ox/www/delivery/ajs.php':'https://serve.themediateam.net/ox/www/delivery/ajs.php');
   var m3_r = Math.floor(Math.random()*99999999999);
   if (!document.MAX_used) document.MAX_used = ',';
   document.write ("<scr"+"ipt type='text/javascript' src='"+m3_u);
   document.write ("?zoneid=157&amp;source=_blank&amp;target=_blank");
   document.write ('&amp;cb=' + m3_r);
   if (document.MAX_used != ',') document.write ("&amp;exclude=" + document.MAX_used);
   document.write (document.charset ? '&amp;charset='+document.charset : (document.characterSet ? '&amp;charset='+document.characterSet : ''));
   document.write ("&amp;loc=" + escape(window.location));
   if (document.referrer) document.write ("&amp;referer=" + escape(document.referrer));
   if (document.context) document.write ("&context=" + escape(document.context));
   if (document.mmm_fo) document.write ("&amp;mmm_fo=1");
   document.write ("'><\/scr"+"ipt>");
//]]>--></script><noscript><a href='https://serve.themediateam.net/ox/www/delivery/ck.php?n=a35f64abc&amp;cb=INSERT_RANDOM_NUMBER_HERE' target='_blank'><img src='https://serve.themediateam.net/ox/www/delivery/avw.php?zoneid=157&amp;source=_blank&amp;cb=INSERT_RANDOM_NUMBER_HERE&amp;n=a35f64ab' border='0' alt='' /></a></noscript>

                    </div>
                    <div id="latest-video">
                        <iframe height="169" src="https://www.youtube.com/embed/gM9uusgDsOo" frameborder="0" allow="accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe>
                        <img src="/static/public/image/YouTube_full-color.svg" alt="">
                        <div>
                            <h5 id="latest-video-text">Video: Project #AORUS-KS Part 1: Components and Case Teardown</h5>
                            <p>November 20 2019 | 16:00</p>
                        </div>
                    </div>
                    
                    
                    <div id="weekInReviews" class="sidebarHighlight">
                        <a href="/week-in-review/">
                            <img src="/static/public/image/week.jpg" alt="Week in review">
                        </a>
                    </div>
                    
                    <div id="shortSignup">
                        <input type='hidden' name='csrfmiddlewaretoken' value='EkyxkaDdGIcPRLvCDoxq9ebcpxdMhd3FgpW50o8aIK96HWzfrdepnIg7gFinb4gC' />
                        <iframe src="/newsletter_signup/" frameborder="0"></iframe>
                        <div style="clear:both;"></div>
                    </div>
                    <div id="skyscrapers" class="clearfix" >
                        <div id="left_articles_container">
                            <div id="top_stories_container" class="clearfix">
                                <h3 class="headingBar">TOP STORIES</h3>
                                <div id="top_stories"></div>
                            </div>
                            <div class="clearfix" id="suggestions_container">
                                <h3 class="headingBar">SUGGESTED FOR YOU</h3>
                                <div id="side_bar_suggestions"></div>
                            </div>
                        </div>
                        <div class="xtag-165">
                            <script type='text/javascript'><!--//<![CDATA[
   var m3_u = (location.protocol=='https:'?'https://serve.themediateam.net/ox/www/delivery/ajs.php':'https://serve.themediateam.net/ox/www/delivery/ajs.php');
   var m3_r = Math.floor(Math.random()*99999999999);
   if (!document.MAX_used) document.MAX_used = ',';
   document.write ("<scr"+"ipt type='text/javascript' src='"+m3_u);
   document.write ("?zoneid=165&amp;source=_blank&amp;target=_blank");
   document.write ('&amp;cb=' + m3_r);
   if (document.MAX_used != ',') document.write ("&amp;exclude=" + document.MAX_used);
   document.write (document.charset ? '&amp;charset='+document.charset : (document.characterSet ? '&amp;charset='+document.characterSet : ''));
   document.write ("&amp;loc=" + escape(window.location));
   if (document.referrer) document.write ("&amp;referer=" + escape(document.referrer));
   if (document.context) document.write ("&context=" + escape(document.context));
   if (document.mmm_fo) document.write ("&amp;mmm_fo=1");
   document.write ("'><\/scr"+"ipt>");
//]]>--></script><noscript><a href='https://serve.themediateam.net/ox/www/delivery/ck.php?n=a35f64abc&amp;cb=INSERT_RANDOM_NUMBER_HERE' target='_blank'><img src='https://serve.themediateam.net/ox/www/delivery/avw.php?zoneid=165&amp;source=_blank&amp;cb=INSERT_RANDOM_NUMBER_HERE&amp;n=a35f64ab' border='0' alt='' /></a></noscript>

                        </div>
                    </div>
                    
                    <div style="float:right;" ></div>
                    <div class="xtag-161">
                        <script type='text/javascript'><!--//<![CDATA[
   var m3_u = (location.protocol=='https:'?'https://serve.themediateam.net/ox/www/delivery/ajs.php':'https://serve.themediateam.net/ox/www/delivery/ajs.php');
   var m3_r = Math.floor(Math.random()*99999999999);
   if (!document.MAX_used) document.MAX_used = ',';
   document.write ("<scr"+"ipt type='text/javascript' src='"+m3_u);
   document.write ("?zoneid=161&amp;source=_blank&amp;target=_blank");
   document.write ('&amp;cb=' + m3_r);
   if (document.MAX_used != ',') document.write ("&amp;exclude=" + document.MAX_used);
   document.write (document.charset ? '&amp;charset='+document.charset : (document.characterSet ? '&amp;charset='+document.characterSet : ''));
   document.write ("&amp;loc=" + escape(window.location));
   if (document.referrer) document.write ("&amp;referer=" + escape(document.referrer));
   if (document.context) document.write ("&context=" + escape(document.context));
   if (document.mmm_fo) document.write ("&amp;mmm_fo=1");
   document.write ("'><\/scr"+"ipt>");
//]]>--></script><noscript><a href='https://serve.themediateam.net/ox/www/delivery/ck.php?n=a35f64abc&amp;cb=INSERT_RANDOM_NUMBER_HERE' target='_blank'><img src='https://serve.themediateam.net/ox/www/delivery/avw.php?zoneid=161&amp;source=_blank&amp;cb=INSERT_RANDOM_NUMBER_HERE&amp;n=a35f64ab' border='0' alt='' /></a></noscript>

                    </div>
                </div>
            </div>
        </div>
        <div class="footerContainer clearfix">
            
            <div class="xtag_container">
                <div class="xtag-169">
                    <script type='text/javascript'><!--//<![CDATA[
   var m3_u = (location.protocol=='https:'?'https://serve.themediateam.net/ox/www/delivery/ajs.php':'https://serve.themediateam.net/ox/www/delivery/ajs.php');
   var m3_r = Math.floor(Math.random()*99999999999);
   if (!document.MAX_used) document.MAX_used = ',';
   document.write ("<scr"+"ipt type='text/javascript' src='"+m3_u);
   document.write ("?zoneid=169&amp;source=_blank&amp;target=_blank");
   document.write ('&amp;cb=' + m3_r);
   if (document.MAX_used != ',') document.write ("&amp;exclude=" + document.MAX_used);
   document.write (document.charset ? '&amp;charset='+document.charset : (document.characterSet ? '&amp;charset='+document.characterSet : ''));
   document.write ("&amp;loc=" + escape(window.location));
   if (document.referrer) document.write ("&amp;referer=" + escape(document.referrer));
   if (document.context) document.write ("&context=" + escape(document.context));
   if (document.mmm_fo) document.write ("&amp;mmm_fo=1");
   document.write ("'><\/scr"+"ipt>");
//]]>--></script><noscript><a href='https://serve.themediateam.net/ox/www/delivery/ck.php?n=a35f64abc&amp;cb=INSERT_RANDOM_NUMBER_HERE' target='_blank'><img src='https://serve.themediateam.net/ox/www/delivery/avw.php?zoneid=169&amp;source=_blank&amp;cb=INSERT_RANDOM_NUMBER_HERE&amp;n=a35f64ab' border='0' alt='' /></a></noscript>

                </div>
            </div>
            
            
            <div id="footer" class="clearfix" >
                <div id="bottom_links_container" class="clearfix" >
                    <div id="bottom-site-links">
                        <h2 class="heading" >Site Links</h2>
                        <ul class="site">
                            <li>
                                <a href="/">Home</a>
                            </li>
                            <li>
                                <a href="/terms/">Terms</a>
                            </li>
                            <li>
                                <a href="/about/">About</a>
                            </li>
                            <li>
                                <a href="mailto:hello@bit-tech.net">Advertise</a>
                            </li>
                            <li>
                                <a href="/scores/">Award Guide</a>
                            </li>
                            <li>
                                <a href="mailto:hello@bit-tech.net?subject=Site Contact Us">Contact Us</a>
                            </li>
                        </ul>
                    </div>
                    <div id="bottom-company-links">
                        <h2 class="heading" >Popular Companies</h2>
                        <ul>
                        
                            <li>
                                <a href="/company/nvidia/">
                                    <span>NVIDIA</span>
                                </a>
                            </li>
                        
                            <li>
                                <a href="/company/amd/">
                                    <span>AMD</span>
                                </a>
                            </li>
                        
                            <li>
                                <a href="/company/intel/">
                                    <span>Intel</span>
                                </a>
                            </li>
                        
                            <li>
                                <a href="/company/corsair/">
                                    <span>Corsair</span>
                                </a>
                            </li>
                        
                            <li>
                                <a href="/company/apple/">
                                    <span>APPLE</span>
                                </a>
                            </li>
                        
                            <li>
                                <a href="/company/google/">
                                    <span>Google</span>
                                </a>
                            </li>
                        
                            <li>
                                <a href="/company/microsoft/">
                                    <span>Microsoft</span>
                                </a>
                            </li>
                        
                            <li>
                                <a href="/company/steam/">
                                    <span>Steam</span>
                                </a>
                            </li>
                        
                            <li>
                                <a href="/company/arm/">
                                    <span>arm</span>
                                </a>
                            </li>
                        
                            <li>
                                <a href="/company/asus/">
                                    <span>ASUS</span>
                                </a>
                            </li>
                        
                            <li>
                                <a href="/company/msi/">
                                    <span>MSI</span>
                                </a>
                            </li>
                        
                            <li>
                                <a href="/company/gigabyte/">
                                    <span>GIGABYTE</span>
                                </a>
                            </li>
                        
                        </ul>
                    </div>
                    <div class="icons">
                        <h2 class="heading">let's get social</h2>
                        <ul>
                            <li>
                                <a href="https://www.facebook.com/bittech">
                                    <img src="/static/public/image/icons/facebook.svg" alt="bit-tech Facebook page">
                                </a>
                            </li>
                            <li>
                                <a href="https://www.twitter.com/bittech">
                                    <img src="/static/public/image/icons/twitter.svg" alt="bit-tech Twitter feed">
                                </a>
                            </li>
                            <li>
                                <a href="https://www.instagram.com/bit_tech/">
                                    <img src="/static/public/image/icons/instagram.svg" alt="bit-tech Instagram feed">
                                </a>
                            </li>
                            <li>
                                <a href="https://www.youtube.com/c/bittech1">
                                    <img src="/static/public/image/icons/youtube.svg" alt="bit-tech YouTube channel">
                                </a>
                            </li>
                            <li>
                                <a href="https://discord.gg/EBGNWYm">
                                    <img src="/static/public/image/icons/discord.svg" alt="bit-tech discord channel">
                                </a>
                            </li>
                            <li>
                                <a href="/rss/">
                                    <img src="/static/public/image/icons/rss.svg" alt="bit-tech RSS feed">
                                </a>
                            </li>
                        </ul>
                    </div>
                    <img src="/static/public/image/bit_tech_logo_white.png" style="float: right;">
                </div>
                <br>
                <div id="bottom_info_container" >
                    <p>Copyright © 2000 - 2019, bit-tech.net. All rights reserved.</p>
                </div>
                <div id="theMediaTeamLogoContainer" style="float:right;">
                    <a href="https://www.themediateam.net/">
                        <img id="theMediaTeamLogo" src="/static/public/image/part_of_the_media_team.png" style="width:100%;" alt="">
                    </a>
                </div>
            </div>
            
            
        </div>
    </div>
</div>

<div class="opaque"></div>
<div id="login_form" style="display: none;" class="login">
    <div class="login-header">
        <div class="login-title">Login Form</div>
        <div class="login-exit"></div>
    </div>
    <div class="login-form"></div>
    <div class="login-footer"></div>
</div>

    <!-- JSON-LD -->
    <script type="text/javascript" src="/static/head/generateFromURL.js"></script>
    <!-- Tangular Template -->
    <script src="/static/external/js/Tangular.min.js"></script>
    <script type="text/template" id="sidebar_article_template">
        <div class="sidebar_article[[ categories_string ]] [[ value.section ]]" >
            <div class="image">
                <a href="[[ value.get_absolute_url ]]">
                    <img src="[[ thumbnail ]]" alt="">
                </a>
            </div>
            <div class="details">
                <div class="title">
                    <a href="[[ value.get_absolute_url ]]">
                        <h4> [[ value.title ]] </h4>
                    </a>
                </div>
            </div>
        </div>
    </script>
    <!-- SCRIPTS -->
    <script type="text/javascript">
        // desktop mobile split
        $.ajaxSetup({
            beforeSend: function(xhr, settings) {
                function getCookie(name) {
                    var cookieValue = null;
                    if (document.cookie && document.cookie != '') {
                        var cookies = document.cookie.split(';');
                        for (var i = 0; i < cookies.length; i++) {
                            var cookie = jQuery.trim(cookies[i]);
                            // Does this cookie string begin with the name we want?
                            if (cookie.substring(0, name.length + 1) == (name + '=')) {
                                cookieValue = decodeURIComponent(cookie.substring(name.length + 1));
                                break;
                            }
                        }
                    }
                    return cookieValue;
                }
                if (!(/^http:.*/.test(settings.url) || /^https:.*/.test(settings.url))) {
                    // Only send the token to relative URLs i.e. locally.
                    xhr.setRequestHeader("X-CSRFToken", getCookie('csrftoken'));
                }
            }
        });
        Ta.settings.delimiters = ["[[", "]]"];
    </script>

    <script src="/static/public/javascript/public.v2.js"></script>
    <script async src="//serve.themediateam.net/ox/www/delivery/asyncjs.php"></script>



<script type='text/javascript'><!--//<![CDATA[
   var m3_u = (location.protocol=='https:'?'https://serve.themediateam.net/ox/www/delivery/ajs.php':'https://serve.themediateam.net/ox/www/delivery/ajs.php');
   var m3_r = Math.floor(Math.random()*99999999999);
   if (!document.MAX_used) document.MAX_used = ',';
   document.write ("<scr"+"ipt type='text/javascript' src='"+m3_u);
   document.write ("?zoneid=181&amp;source=_blank&amp;target=_blank");
   document.write ('&amp;cb=' + m3_r);
   if (document.MAX_used != ',') document.write ("&amp;exclude=" + document.MAX_used);
   document.write (document.charset ? '&amp;charset='+document.charset : (document.characterSet ? '&amp;charset='+document.characterSet : ''));
   document.write ("&amp;loc=" + escape(window.location));
   if (document.referrer) document.write ("&amp;referer=" + escape(document.referrer));
   if (document.context) document.write ("&context=" + escape(document.context));
   if (document.mmm_fo) document.write ("&amp;mmm_fo=1");
   document.write ("'><\/scr"+"ipt>");
//]]>--></script><noscript><a href='https://serve.themediateam.net/ox/www/delivery/ck.php?n=a355bc27c&amp;cb=INSERT_RANDOM_NUMBER_HERE' target='_blank'><img src='https://serve.themediateam.net/ox/www/delivery/avw.php?zoneid=181&amp;source=_blank&amp;cb=INSERT_RANDOM_NUMBER_HERE&amp;n=a355bc27' border='0' alt='' /></a></noscript>






    <script type="text/javascript">

        // handles loading multiple recaptcha
        function loadRecaptcha() {

            // through elements that include recaptcha in their id
            $('[id*="recaptcha"]').each(function(index, value){

                // calls render on recaptcha to the id of this
                grecaptcha.render($(this).attr('id'), {
                    'sitekey' : '6LcUVyQUAAAAAHLR57m4CKdmLkFXnGho75painXi',
                });
            });
        };
    </script>

    <!-- script for polls -->
    
    <script src="/static/cms_surveys/js/base_v2.js"></script>

    <script>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</script>
    
    <script type='text/javascript'><!--//<![CDATA[
        document.MAX_ct0 = unescape('INSERT_ENCODED_CLICKURL_HERE');
        var m3_u = (location.protocol=='https:'?'https://serve.themediateam.net/ox/www/delivery/ajs.php':'http://serve.themediateam.net/ox/www/delivery/ajs.php');
        var m3_r = Math.floor(Math.random()*99999999999);
        if (!document.MAX_used) document.MAX_used = ',';
        document.write ("<scr"+"ipt type='text/javascript' src='"+m3_u);
        document.write ("?zoneid=263&amp;source=_blank&amp;target=_blank");
        document.write ('&amp;cb=' + m3_r);
        if (document.MAX_used != ',') document.write ("&amp;exclude=" + document.MAX_used);
        document.write (document.charset ? '&amp;charset='+document.charset : (document.characterSet ? '&amp;charset='+document.characterSet : ''));
        document.write ("&amp;loc=" + escape(window.location));
        if (document.referrer) document.write ("&amp;referer=" + escape(document.referrer));
        if (document.context) document.write ("&context=" + escape(document.context));
        if ((typeof(document.MAX_ct0) != 'undefined') && (document.MAX_ct0.substring(0,4) == 'http')) {
        document.write ("&amp;ct0=" + escape(document.MAX_ct0));
        }
        if (document.mmm_fo) document.write ("&amp;mmm_fo=1");
        document.write ("'><\/scr"+"ipt>");
        //]]>-->
    </script>
    
    <script>
        
        // media query change
        function WidthChange(mq) {
            if (mq.matches) {
                // window width is at least 950px
                $(header).css({
                    'height': '65px',
                    'width': '100%',
                    'background-color': 'rgb(245, 245, 245)',
                    // 'color': 'white',
                    'position': 'fixed',
                    'bottom': '0px',
                    'z-index': '9999',
                    'font-size': '1vw',
                    'text-align': 'center',
                    'max-height': '55px',
                    'font-size': '14px',
                })
            } else {
                // window width is less than 950px
                $(header).css({
                    'height': '90px',
                    'width': '100%',
                    'background-color': 'rgb(245, 245, 245)',
                    // 'color': 'white',
                    'position': 'fixed',
                    'bottom': '0px',
                    'z-index': '9999',
                    'font-size': '3vw',
                    'text-align': 'center',
                    'max-height': '115px',
                    'font-size': '14px',
                })
            }
        }

        if (!localStorage.getItem("bit-tech-privacy")||localStorage.getItem("bit-tech-privacy")==='false') {
            header = document.createElement('div')
            header.setAttribute('id', 'GDPR');
            // media query event handler
            if (matchMedia) {
                const mq = window.matchMedia("(min-width: 950px)");
                mq.addListener(WidthChange);
                WidthChange(mq);
            }
            text = document.createElement('p');
            text.innerHTML = 'In line with recent changes to data protection legislation in the UK and Europe we would like to direct you to our updated <a href="https://www.themediateam.net/privacy/" alt="The Media Team privacy policy">Privacy Policy here</a>.';
            $(text).css({
                'margin': '0px'
            })
            header.appendChild(text)
            button = document.createElement('button')
            button.innerHTML = 'Dismiss';
            $(button).css({
                'position': 'absolute',
                'bottom': '5px',
                'left': '0px',
                'right': '0px',
                'left': '0px',
                'width': '65px',
                'margin-left': 'auto',
                'margin-right': 'auto',
                'background-color': '#555555',
                'border': 'none',
                'color': 'white',
                'padding': '5px',
                'text-align': 'center',
                'text-decoration': 'none',
            })
            button.onclick = function() {
                localStorage.setItem('bit-tech-privacy', 'true');
                $(header).css({
                    'display': 'none'
                })
            }
            header.appendChild(button);
            document.body.appendChild(header);
        }
    </script>

    
    <script>
        $('a[href*="thinq.co.uk"]').each(function(i, v){
            $(v).after($(v).text());
            $(v).remove();
        });
    </script>
    <style>
        body, #blurBackground {
            background-attachment: fixed !important;
        }
    </style>

    <noscript><a href='http://serve.themediateam.net/ox/www/delivery/ck.php?n=a43f7edf&amp;cb=INSERT_RANDOM_NUMBER_HERE' target='_blank'><img src='http://serve.themediateam.net/ox/www/delivery/avw.php?zoneid=263&amp;source=_blank&amp;cb=INSERT_RANDOM_NUMBER_HERE&amp;n=a43f7edf&amp;ct0=INSERT_ENCODED_CLICKURL_HERE' border='0' alt='' /></a></noscript>
    
<script type="text/template" id="comments_template">
    <div class="comment col-1-1" id="comment_[[ id ]]" data-member="[[ user_id ]]" data-id="[[ id ]]" data-username="[[ username ]]">
        <div class="heading clearfix">
            <h4>[[ title ]]</h4>
        </div>
        <div class="comment_text_container">
            <div class="comment_text"></div>
            
            <img class="quote-icon" src="/static/public/image/icons/comment_reply.png" alt="">
        </div>
    </dv>
</script>

<script type="text/javascript">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</script>


</body>
</html>

