




<!DOCTYPE html>
<html lang="en">
<head>
    <meta charset="UTF-8">
    
    <script src="/static/external/js/jquery-1.12.3.min.js"></script>
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
    <meta name="keywords" content="
        
            BYOC,
        
            i61,
        
            insomnia 61,
        
            Lan,
        
            multiplay
        
    " />
    <!-- RSS FEEDS -->
    <link rel="alternate" href="/xml/all.rss" type="application/rss+xml" charset="utf-8" title="bit-tech feed" />
    <link rel="alternate" href="/xml/bittech.rss" type="application/rss+xml" charset="utf-8" title="Article feed" />
    <link rel="alternate" href="/xml/news.rss" type="application/rss+xml" charset="utf-8" title="News feed" />
    <link rel="alternate" href="/xml/hardware.rss" type="application/rss+xml" charset="utf-8" title="Hardware feed" />
    <link rel="alternate" href="/xml/gaming.rss" type="application/rss+xml" charset="utf-8" title="Gaming feed" />
    <link rel="alternate" href="/xml/modding.rss" type="application/rss+xml" charset="utf-8" title="Modding feed" />
    <link rel="alternate" href="/xml/blog.rss" type="application/rss+xml" charset="utf-8" title="Blog feed" />
    <link rel="alternate" href="/xml/blog/podcasts.rss" type="application/rss+xml" charset="utf-8" title="Podcasts feed" />
    <link rel="alternate" href="/xml/bits.rss" type="application/rss+xml" charset="utf-8" title="Bits feed" />
    <link href="https://fonts.googleapis.com/css?family=Open+Sans" rel="stylesheet">
    <link href="https://fonts.googleapis.com/css?family=Roboto" rel="stylesheet">

    <!-- OLD STYLES -->
    <link rel="apple-touch-icon" href="//images.bit-tech.net/images/webclip.png" />
    
        <!-- <link rel="stylesheet" href="http://images.bit-tech.net/style/article.css" type="text/css" media="all" charset="utf-8" /> -->
        <!--[if IE 6]>
        <link rel="stylesheet" href="http://images.bit-tech.net/style/ie6/article.css" type="text/css" media="all" charset="utf-8" />
        <![endif]-->
        <!--[if IE 7]>
        <link rel="stylesheet" href="http://images.bit-tech.net/style/ie7/article.css" type="text/css" media="all" charset="utf-8" />
        <![endif]-->
    
    <link rel="stylesheet" href="/static/public/css/legacy.css" />
    <link rel="stylesheet" href="/static/public/css/legacy_graphs.css" />
    <!-- NEW STYLES -->
    <link rel="shortcut icon" href="/static/public/image/favicon.ico" />
    <link rel="stylesheet" href="/static/public/css/simplegrid_nopadding.css" />
    <link rel="stylesheet"  href="/static/public/css/main.css" />
    <link rel="stylesheet" href="/static/external/css/font-awesome-4.6.3/css/font-awesome.min.css">
    
        <link rel="stylesheet"  href="/static/public/css/section/others.css" />
    
    
        <link rel="stylesheet"  href="/static/public/css/category/gaming.css" />
    
    <style>
        body{
            margin:0;
            background:#000 url('//images.bit-tech.net/images/backgrounds/body-20160101.jpg') no-repeat fixed 50% 0;
        }
        #side_column{
            float:right;
        }
        #blurBackground{
            margin: 0;
            background: #000 url('//images.bit-tech.net/images/backgrounds/body-20160101.jpg') no-repeat fixed 50% 0;
        }
        #blurBackground.blurred{
            filter: blur(4px);
            -webkit-filter: blur(4px);
            filter: blur(4px);
            -o-filter: blur(4px);
            -ms-filter: blur(4px);
            -moz-filter: blur(4px);
            /* -webkit-filter: blur(4px); */
        }

        #skin {
            position: absolute;
            left: 0px;
            top: 0px;
            right: 0px;
            bottom: 0px;
            width: 100%;
        }

        #skin > #skinclick {
            display: block;
            width: 100%;
            height: 100%;
        }

        body .pageContainer {
            z-index: 9999;
        }

        #skin {
            position: absolute;
            left: 0px;
            top: 0px;
            right: 0px;
            bottom: 0px;
            width: 100%;
        }

        #skin > #skinclick {
            display: block;
            width: 100%;
            height: 100%;
        }

        body .pageContainer {
            z-index: 9999;
        }

    </style>
    <script type="text/javascript">
        document.cutoff = 980;

        var SELENIUM_ERRORS = [];

        window.onerror = function (msg, source, lineno) {
            SELENIUM_ERRORS.push([msg, source, lineno]);
        };

    </script>
    
    
        
        <link rel="stylesheet"  href="/static/public/css/detail.css" />
        

<!-- for google -->

<title>Taking a Walk Around Insomnia 61 | bit-tech.net</title>
<meta name="description" content="We travelled to the Birmingham NEC to take a walk around Insomnia 61 - the biggest gaming festival in the UK!" />
<meta name="robots" content="index, follow" />
<meta name="googlebot" content="index, follow" />
<meta charset="utf-8">
<!-- for facebook -->

<meta property="og:url" content="/others/gaming/taking-a-walk-around-insomnia-61/1/" />
<meta property="og:title" content="Taking a Walk Around Insomnia 61 | bit-tech.net" />
<meta property="og:description" content="We travelled to the Birmingham NEC to take a walk around Insomnia 61 - the biggest gaming festival in the UK!" />
<meta property="og:image" content="/media/image/2017/8/3b904ce3-defa-4316-b300-087c28a4abde.png" />
<meta property="fb:app_id" content="1859842647618090"/>

    <meta property="og:type" content="article" />


    <meta property="og:locale" content="en_UK" />

<!-- for twitter -->

<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@bittech" />
<meta name="twitter:creator" content="@bittech" />
<meta name="twitter:title" content="Taking a Walk Around Insomnia 61 | bit-tech.net">
<meta name="twitter:description" content="We travelled to the Birmingham NEC to take a walk around Insomnia 61 - the biggest gaming festival in the UK!" />
<meta name="twitter:image" content="/media/image/2017/8/3b904ce3-defa-4316-b300-087c28a4abde.png" />

<!-- Schema.org markup for Google+ -->
<meta itemprop="name" content="Taking a Walk Around Insomnia 61 | bit-tech.net">
<meta itemprop="description" content="We travelled to the Birmingham NEC to take a walk around Insomnia 61 - the biggest gaming festival in the UK!">
<meta itemprop="image" content="/media/image/2017/8/3b904ce3-defa-4316-b300-087c28a4abde.png">
<!-- for amazon -->

    <link rel="search" type="application/opensearchdescription+xml" href="/opensearch_xml/" title="https://bit-tech.net search" />

<!-- more on meta tags and SEO -->


    
    
    
    <!-- sharethis buttons -->
    <script type='text/javascript' src='//platform-api.sharethis.com/js/sharethis.js#property=594b47e099baea0012f9c055&product=inline-share-buttons' async='async'></script>
    <link href="https://file.myfontastic.com/n6vo44Re5QaWo8oCKShBs7/icons.css" rel="stylesheet">

</head>
<body>
<div id="blurBackground">
    <a name="top" id="top"></a>
    <div class="pageContainer">
        <div id="brandHeader" class="clearfix">
            
                <a href="/category/gaming/"><img class="logo" src="/static/public/image/bit_gamer_logo.png"></a>
            
            <div class="xtag-153">
                <script type='text/javascript'><!--//<![CDATA[
   var m3_u = (location.protocol=='https:'?'https://serve.themediateam.net/ox/www/delivery/ajs.php':'http://serve.themediateam.net/ox/www/delivery/ajs.php');
   var m3_r = Math.floor(Math.random()*99999999999);
   if (!document.MAX_used) document.MAX_used = ',';
   document.write ("<scr"+"ipt type='text/javascript' src='"+m3_u);
   document.write ("?zoneid=153&amp;source=_blank&amp;target=_blank");
   document.write ('&amp;cb=' + m3_r);
   if (document.MAX_used != ',') document.write ("&amp;exclude=" + document.MAX_used);
   document.write (document.charset ? '&amp;charset='+document.charset : (document.characterSet ? '&amp;charset='+document.characterSet : ''));
   document.write ("&amp;loc=" + escape(window.location));
   if (document.referrer) document.write ("&amp;referer=" + escape(document.referrer));
   if (document.context) document.write ("&context=" + escape(document.context));
   if (document.mmm_fo) document.write ("&amp;mmm_fo=1");
   document.write ("'><\/scr"+"ipt>");
//]]>--></script><noscript><a href='http://serve.themediateam.net/ox/www/delivery/ck.php?n=a35f64acc&amp;cb=INSERT_RANDOM_NUMBER_HERE' target='_blank'><img src='http://serve.themediateam.net/ox/www/delivery/avw.php?zoneid=153&amp;source=_blank&amp;cb=INSERT_RANDOM_NUMBER_HERE&amp;n=a35f64ac' border='0' alt='' /></a></noscript>

            </div>
        </div>
        
            <div id="navContainer" class="clearfix">
                <div id="mainNav" class="clearfix">
                    
                    <ul id="topList" class="clearfix">
                        <a href="/">
                            <li id="topListHome" class="topLi " >
                                <div class="topLi-icon fa fa-home" style="display:none;"></div>
                                <span>Home</span>
                            </li>
                        </a>
                        
                            <a href="/category/tech/">
                                <li data-section="tech" class="topLi " >
                                    <div class="topLi-icon" style="display:none;"></div>
                                    <span>Tech</span>
                                </li>
                            </a>
                        
                            <a href="/category/modding/">
                                <li data-section="modding" class="topLi " >
                                    <div class="topLi-icon" style="display:none;"></div>
                                    <span>Modding</span>
                                </li>
                            </a>
                        
                            <a href="/category/gaming/">
                                <li data-section="gaming" class="topLi active" >
                                    <div class="topLi-icon" style="display:none;"></div>
                                    <span>Gaming</span>
                                </li>
                            </a>
                        
                        <a href="/contact-us/"> <!-- view also matches static pages -->
                            <li id="topListContactUs" >
                                <div class="topLi-icon fa fa-envelope" style="display:none;"></div>
                                <span>Contact us</span>
                            </li>
                        </a>
                        <a href="//forums.bit-tech.net">
                            <li id="topListForum" >
                                <div class="topLi-icon fa fa-comments" style="display:none;"></div>
                                <span>Forum</span>
                            </li>
                        </a>
                    </ul>
                    <div class="right_box">
                        <div class="icons">
                            <a href="https://www.facebook.com/bittech">
                                <img src="/static/public/image/facebook_icon.png">
                            </a>
                            <a href="http://www.twitter.com/bittech">
                                <img src="/static/public/image/twitter_icon.png">
                            </a>
                            <a href="/rss/">
                                <img src="/static/public/image/rss_icon.png">
                            </a>
                        </div>
                    </div>
                    
                    <div class="account-options">
                        
                            <a id="accounts_icon" href="/login/">
                                <span class="account-option">Login</span>
                            </a>
                            <a href="/register/">
                                <span class="account-option">Register</span>
                            </a>
                        
                    </div>
                </div>
                
                <div id="subNav" class="clearfix">
                    <ul id="secondList" style="display: inline-flex; max-width: initial; width: initial;">
                        <li >
                            
                                <a href="/category/gaming/">
                            
                                <span>All</span>
                            </a>
                        </li>
                        
                            <li class="" >
                                
                                    <a href="/news/gaming/">
                                
                                    <span>News</span>
                                </a>
                            </li>
                        
                            <li class="" >
                                
                                    <a href="/reviews/gaming/">
                                
                                    <span>Reviews</span>
                                </a>
                            </li>
                        
                            <li class="" >
                                
                                    <a href="/features/gaming/">
                                
                                    <span>Features</span>
                                </a>
                            </li>
                        
                            <li class="" >
                                
                                    <a href="/previews/gaming/">
                                
                                    <span>Previews</span>
                                </a>
                            </li>
                        
                            <li class="" >
                                
                                    <a href="/guides/gaming/">
                                
                                    <span>Guides</span>
                                </a>
                            </li>
                        
                            <li class="" >
                                
                                    <a href="/blogs/gaming/">
                                
                                    <span>Blogs</span>
                                </a>
                            </li>
                        
                            <li class="" >
                                
                                    <a href="/competitions/gaming/">
                                
                                    <span>Competitions</span>
                                </a>
                            </li>
                        
                            <li class="" >
                                
                                    <a href="/press-releases/gaming/">
                                
                                    <span>Press Releases</span>
                                </a>
                            </li>
                        
                    </ul>
                    <div class="search">
                        <form id="search_form" action="/search/" method="get" accept-charset="utf-8">
                            <input type="text" name="q" value="" placeholder="Search bit-tech"/>
                            <span class="button">
                                <input type="submit" value="">
                            </span>
                        </form>
                    </div>
                </div>
                
                    <div id="anotherSubNav" class="clearfix">
                        <ul id="thirdList" style="display: inline-flex; max-width: initial; width: initial;">
                            <li class="active">
                                
                                    <a href="/others/gaming/">
                                
                                    <span>All</span>
                                </a>
                            </li>
                            
                                
                            
                                
                            
                                
                                    
                                        <li  >
                                            <a href="
                                                /others/gaming/apple/
                                            ">
                                                <span>Apple</span>
                                            </a>
                                        </li>
                                    
                                        <li  >
                                            <a href="
                                                /others/gaming/linux/
                                            ">
                                                <span>Linux</span>
                                            </a>
                                        </li>
                                    
                                        <li  >
                                            <a href="
                                                /others/gaming/mobile-gaming/
                                            ">
                                                <span>Mobile Gaming</span>
                                            </a>
                                        </li>
                                    
                                        <li  >
                                            <a href="
                                                /others/gaming/nintendo/
                                            ">
                                                <span>Nintendo</span>
                                            </a>
                                        </li>
                                    
                                        <li  >
                                            <a href="
                                                /others/gaming/pc/
                                            ">
                                                <span>PC</span>
                                            </a>
                                        </li>
                                    
                                        <li  >
                                            <a href="
                                                /others/gaming/playstation/
                                            ">
                                                <span>Playstation</span>
                                            </a>
                                        </li>
                                    
                                        <li  >
                                            <a href="
                                                /others/gaming/retro/
                                            ">
                                                <span>Retro</span>
                                            </a>
                                        </li>
                                    
                                        <li  >
                                            <a href="
                                                /others/gaming/virtual-reality/
                                            ">
                                                <span>Virtual Reality</span>
                                            </a>
                                        </li>
                                    
                                        <li  >
                                            <a href="
                                                /others/gaming/xbox/
                                            ">
                                                <span>Xbox</span>
                                            </a>
                                        </li>
                                    
                                
                            
                        </ul>
                    </div>
                
                
            </div>
        
        <div class="xtag-173">
            <script type='text/javascript'><!--//<![CDATA[
   var m3_u = (location.protocol=='https:'?'https://serve.themediateam.net/ox/www/delivery/ajs.php':'http://serve.themediateam.net/ox/www/delivery/ajs.php');
   var m3_r = Math.floor(Math.random()*99999999999);
   if (!document.MAX_used) document.MAX_used = ',';
   document.write ("<scr"+"ipt type='text/javascript' src='"+m3_u);
   document.write ("?zoneid=173&amp;source=_blank&amp;target=_blank");
   document.write ('&amp;cb=' + m3_r);
   if (document.MAX_used != ',') document.write ("&amp;exclude=" + document.MAX_used);
   document.write (document.charset ? '&amp;charset='+document.charset : (document.characterSet ? '&amp;charset='+document.characterSet : ''));
   document.write ("&amp;loc=" + escape(window.location));
   if (document.referrer) document.write ("&amp;referer=" + escape(document.referrer));
   if (document.context) document.write ("&context=" + escape(document.context));
   if (document.mmm_fo) document.write ("&amp;mmm_fo=1");
   document.write ("'><\/scr"+"ipt>");
//]]>--></script><noscript><a href='http://serve.themediateam.net/ox/www/delivery/ck.php?n=a35f64abc&amp;cb=INSERT_RANDOM_NUMBER_HERE' target='_blank'><img src='http://serve.themediateam.net/ox/www/delivery/avw.php?zoneid=173&amp;source=_blank&amp;cb=INSERT_RANDOM_NUMBER_HERE&amp;n=a35f64ab' border='0' alt='' /></a></noscript>

        </div>
        <div id="bodyContainer" class="clearfix">
            <div class="clearfix" style="clear:both;">
                <div id="main_column">
                    
    
    
    
        
            

<link rel="stylesheet" type="text/css" href="/static/public/modal/baguetteBox.css">
<style>
    .image-source-link {
        color: #98C3D1;
    }

    .mfp-with-zoom .mfp-container,
    .mfp-with-zoom.mfp-bg {
        opacity: 0;
        -webkit-backface-visibility: hidden;
        /* ideally, transition speed should match zoom duration */
        -webkit-transition: all 0.3s ease-out; 
        -moz-transition: all 0.3s ease-out; 
        -o-transition: all 0.3s ease-out; 
        transition: all 0.3s ease-out;
    }

    .mfp-with-zoom.mfp-ready .mfp-container {
            opacity: 1;
    }
    .mfp-with-zoom.mfp-ready.mfp-bg {
            opacity: 0.8;
    }

    .mfp-with-zoom.mfp-removing .mfp-container, 
    .mfp-with-zoom.mfp-removing.mfp-bg {
        opacity: 0;
    }
</style>
<div class="articleCopy">
    <div style="display: flex; align-items: center;">
        <div class="object_headings" style="flex-grow: 1;">
            <h2 class="heading" >Taking a Walk Around Insomnia 61</h2>
            <div class="clearfix">
                <p class="author" >Written by
                    <a href="/author/dave-alcock/">
                        Dave Alcock
                    </a>
                </p>
                <div class="sharethis-inline-share-buttons" ></div>
            </div>
            <p class="datetime" >August 30, 2017 // 6 p.m.</p>
            
                
                    <p class="tags" >Tags: <a href="/tag/byoc/">#byoc</a> <a href="/tag/i61/">#i61</a> <a href="/tag/insomnia-61/">#insomnia-61</a> <a href="/tag/lan/">#lan</a> <a href="/tag/multiplay/">#multiplay</a> </p>
                
            
            
        </div>
    </div>

    
        <div id="top_thumbnail" class="clearfix" >
            <img src="/media/image/2017/8/3b904ce3-defa-4316-b300-087c28a4abde.png" alt="">
        </div>
    

    
        
            <div id="first_page_turner" class="page_turner clearfix" >
                

                <select name="pages" id="select_pages" class="buttons_1" onchange="location = this.value;">
                    
                        
                    
                        
                            <option selected value="
                                /others/gaming/taking-a-walk-around-insomnia-61/1/
                            ">1 - Taking a Walk Around Insomnia 61</option>
                        
                    
                        
                            <option  value="
                                /others/gaming/taking-a-walk-around-insomnia-61/2/
                            ">2 - Taking a Walk Around Insomnia 61</option>
                        
                    
                </select>

                
                    <a href="
                        /others/gaming/taking-a-walk-around-insomnia-61/2/
                    ">
                        <button class="next_button" >Next <img id="right_arrow" class="arrow" src="/static/public/image/nav_bar_arrow_white_right.png" alt=""></button>
                    </a>
                
            </div>
        
    

    <div id="page_body" class="object_body">
        <div><div><div><p></p><p>At the weekend, bit-tech descended on the largest LAN in the UK - Insomnia 61! If you have never been to one before, it's an event all about gaming and hardware where you can go along, set up your computer, and game until you pass out. In recent years, it has become more&nbsp;<span style="color: inherit; font-size: inherit;">commercialised</span>, but it's still a fantastic event where you can meet some great people. I went along hoping to see some amazing mods on show like previous summer events, but for some reason, there were only a couple there - <span style="color: inherit; font-size: inherit;">booooo</span>!&nbsp;</p><p>Still, let's have a walk around and see what the companies did have on show.</p><p>Corsair made the trip happen for me, so that is where I spent most of my&nbsp;time. As per usual, all of the Corsair crew made me feel welcome and had all of their gear on show. As Corsair partnered with Scan, it meant that it was also able to sell products at the event, which went down a storm!</p><p><img src="https://www.bit-tech.net/media/image/2017/8/1b160025-533a-4e81-a5ba-e86c7284d36c.jpg" alt="" caption="" style="float: none;" width="200"><img src="https://www.bit-tech.net/media/image/2017/8/0d2d095b-3382-4ea0-9d78-f800f2b0a533.jpg" alt="" caption="" style="float: none;" width="200"><img src="https://www.bit-tech.net/media/image/2017/8/eab736b7-8921-4ddd-b2f1-de92613fc151.jpg" alt="" caption="" style="float: none;" width="200"></p><p>One thing I always say when reviewing peripherals is that they are very much personal preference, and this is where events can really be worth attending. You can put your hands on all of the keyboards and mice and find something that suits you. Corsair had a nice little hands-on area dedicated to its full range of peripherals. There were also a couple of rather nice builds and a whole set of Corsair One systems which were powering games that customers could play on.</p><p><img src="https://www.bit-tech.net/media/image/2017/8/2a8b0232-96cc-4b68-ba16-1420663e33f3.jpg" alt="" caption="" style="float: none;" width="200"><img src="https://www.bit-tech.net/media/image/2017/8/cf32a738-21c9-4818-a0fd-35982125ddfa.jpg" alt="" caption="" style="float: none;" width="200"><img src="https://www.bit-tech.net/media/image/2017/8/ab7f0f94-d0d8-4215-98d6-37336061e642.jpg" alt="" caption="" style="float: none;" width="200"></p><p>Throughout the event, Corsair had some of its streamers pop along and stream live from Insomnia. This was great and pulled in a massive crowd, especially when MarzBar, Lt Zonda, and BoMenzzz popped along.</p><p><img src="https://www.bit-tech.net/media/image/2017/8/19af7801-a8d2-455f-9927-683a046897cd.jpg" alt="" caption="" style="float: none;" width="200"><img src="https://www.bit-tech.net/media/image/2017/8/11e32bdd-9714-4f6b-8dbe-882e959109e7.jpg" alt="" caption="" style="float: none;" width="200"><img src="https://www.bit-tech.net/media/image/2017/8/0a001c5b-1897-4e2a-a41f-89d6c67f27d0.jpg" alt="" caption="" style="float: none;" width="200"></p><p>As some of you will know, I'm a big fan of keyboards, and Bosse Computers was there showing off a rather large range of Ducky, Vortex, 1st Player, and Mistel boards. I always enjoy a chat with these guys, as these are some of the most unique boards on the market. This time, Bosse also had RorzCustomPC on the stand who was showing off some great coatings for PCs and also some rather nice cable sleeving - maybe we will see more of him in the future!<br></p><p><img src="https://www.bit-tech.net/media/image/2017/8/73a58167-2c8d-48cc-80ba-beed0491dbae.jpg" alt="" caption="" style="float: none;" width="200"><img src="https://www.bit-tech.net/media/image/2017/8/2dace133-2ad5-439d-bb23-492a2b64f8db.jpg" alt="" caption="" style="float: none;" width="200"><img src="https://www.bit-tech.net/media/image/2017/8/841683fa-a82a-4911-b71f-f011f79eb853.jpg" alt="" caption="" style="float: none;" width="200"></p><p>As always, the Asus crew was there in force showing off some rather nice little computers. This has been the first event in a long time that one of my systems hasn't been on show with these guys, so it was quite strange being there and not getting asked loads of questions!&nbsp;</p><p><img src="https://www.bit-tech.net/media/image/2017/8/8a83d7b5-91a3-4d03-bdc3-088b16acb23c.jpg" alt="" caption="" style="float: none;" width="300"><img src="https://www.bit-tech.net/media/image/2017/8/ded545c7-cf00-479d-b964-28f7a92bcebe.jpg" alt="" caption="" style="float: none;" width="300"></p>There were some new peripherals on show, some of which we have already reviewed and some which we will no doubt be looking at when samples become available. I also had a chat with Kris Huang, the ROG Senior Director for motherboards and peripherals. You can find a very cut down version of our chat <a href="https://www.bit-tech.net/features/tech/asus-interview-kris-huang-rog-senior-director-for-motherboards-and-peripherals/1/">here</a>.<br><p><img src="https://www.bit-tech.net/media/image/2017/8/dd20a2e3-3e99-4ef2-8ad0-d5aa85d9183a.jpg" alt="" caption="" style="float: none;" width="200"><img src="https://www.bit-tech.net/media/image/2017/8/3912ac11-63a1-4343-9453-a076abe15f2a.jpg" alt="" caption="" style="float: none;" width="200"><img src="https://www.bit-tech.net/media/image/2017/8/169e175a-c202-49aa-8913-02a7f5f88ce8.jpg" alt="" caption="" style="float: none;" width="200"></p><p>CyperPowerPC teamed up with multiple companies such as In Win and Cooler Master. As always, the In Win machines were beautiful, especially the In Win Tou 2.0! There was also plenty of computers for users to use and game on.<br></p><p><img src="https://www.bit-tech.net/media/image/2017/8/2d82df33-22ee-4af2-9955-73775bb689df.jpg" alt="" caption="" style="float: none;" width="200"><img src="https://www.bit-tech.net/media/image/2017/8/9a2d2049-fc4c-49e3-b3a4-6afe6291e55b.jpg" alt="" caption="" style="float: none;" width="200"><img src="https://www.bit-tech.net/media/image/2017/8/2c78ba52-f1e8-47de-b995-8834812398e1.jpg" alt="" caption="" style="float: none;" width="200"></p><p>The Cooler Master cases that were on show were rather tasty too, I especially like the HAF H500P, which I know a lot of people are excited for. Still no solid release date or pricing, but from what I have been told, I think people will be rather happy!</p><p><img src="https://www.bit-tech.net/media/image/2017/8/1709fb9d-9b40-4912-a4f7-26f369b70377.jpg" alt="" caption="" style="float: none;" width="300"><img src="https://www.bit-tech.net/media/image/2017/8/b90395c4-79f2-421c-a5ff-ef966a2c1fef.jpg" alt="" caption="" style="float: none;" width="300"></p><p>As is the trend this year, Cooler Master and CyberPowerPC brought along a bunch of streamers to live-stream from the event. A special shout out goes to Steven Kiberton, someone who I sometimes watch when I have some free time! It is great to see Cooler Master backing him. Cooler Master also had an awesome VR parachute simulator; this thing is amazing and has really made me want to look at getting a VR kit. Basically, it feels like you're really parachuting down through floating rings - very surreal but a lot of fun.</p><p></p></div></div></div><br>
    </div>

    


    
        
            <div id="last_page_turner" class="page_turner clearfix" >
                

                <select name="pages" id="select_pages" class="buttons_1" onchange="location = this.value;">
                    
                        
                    
                        
                            <option selected value="
                                /others/gaming/taking-a-walk-around-insomnia-61/1/
                            ">1 - Taking a Walk Around Insomnia 61</option>
                        
                    
                        
                            <option  value="
                                /others/gaming/taking-a-walk-around-insomnia-61/2/
                            ">2 - Taking a Walk Around Insomnia 61</option>
                        
                    
                </select>

                
                    <a href="
                        /others/gaming/taking-a-walk-around-insomnia-61/2/
                    ">
                        <button class="next_button" >Next <img id="right_arrow" class="arrow" src="/static/public/image/nav_bar_arrow_white_right.png" alt=""></button>
                    </a>
                
            </div>
        
    

     <div id="comments_container" class="comments" style='overflow: auto;'>

        <div id="comments_action">
            
                <p class="login-link">Want to comment? Log in.</p>
            
        </div>

        <div id="current_comments" class="clearfix" >

        </div>
        <div id="comments_nav" class="col-1-1">
            <div id="batch_numbers"></div>
        </div>

        <div id="quick_comment" class="clearfix">
            <div class="heading">
                <h4>QUICK COMMENT</h4>
            </div>
            <textarea id="quick_comment_text"></textarea>
            <button id="quick_comment_submit">COMMENT</button>
        </div>
    </div>

    

        <div id="related_articles_container" class="clearfix">
            <h3 class="headingBar">RELATED ARTICLES</h3>
            
                <div class="related_article features peripherals tech motherboards " >
                    <div class="image">
                        <a href="/features/tech/asus-interview-kris-huang-rog-senior-director-for-motherboards-and-peripherals/1/">
                            <img src="/media/image/2017/8/af96417f-9b68-4912-9ee1-b618b6ea9d9a.png" alt="">
                        </a>
                    </div>
                    <div class="details">
                        <div class="title">
                            <a href="/features/tech/asus-interview-kris-huang-rog-senior-director-for-motherboards-and-peripherals/1/">
                                <h4>Asus Interview: Kris Huang (ROG Senior Director for Motherboards and Peripherals)</h4>
                            </a>
                        </div>
                        <div class="description">
                            <p>A quick chat at Insomnia 61 about Asus&#39; latest products.</p>
                        </div>
                    </div>
                </div>
            
                <div class="related_article news pc gaming " >
                    <div class="image">
                        <a href="/news/gaming/pc/game-multiplay-gaming-arena/1/">
                            <img src="//images.bit-tech.net/news_images/2016/07/game-multiplay-gaming-arena/featured_double.jpg" alt="">
                        </a>
                    </div>
                    <div class="details">
                        <div class="title">
                            <a href="/news/gaming/pc/game-multiplay-gaming-arena/1/">
                                <h4>Game launches Multiplay Gaming Arena in Manchester</h4>
                            </a>
                        </div>
                        <div class="description">
                            <p>Ten Overclockers UK PCs, one Vive.</p>
                        </div>
                    </div>
                </div>
            
                <div class="related_article news tech " >
                    <div class="image">
                        <a href="/news/tech/the-best-of-multiplay-i55/1/">
                            <img src="//images.bit-tech.net/news_images/2015/09/the-best-of-multiplay-i55/featured_double.jpg" alt="">
                        </a>
                    </div>
                    <div class="details">
                        <div class="title">
                            <a href="/news/tech/the-best-of-multiplay-i55/1/">
                                <h4>The Best of Multiplay i55</h4>
                            </a>
                        </div>
                        <div class="description">
                            <p>A quick look at some of the best things hardware and modding-wise from the latest i-series event</p>
                        </div>
                    </div>
                </div>
            
        </div>

    

    

        

    
</div>


<script src="/static/public/modal/baguetteBox.js"> </script>

        
    

    <a href="//forums.bit-tech.net/index.php?threads/330947">View this in the forums</a>



                </div>
                <div id="side_column" class="grid_6">
                    <div id="banners">
                        <div class="side_bar_banners" >
                            <a href="//forums.bit-tech.net/index.php?forums/project-logs.42/">
                                <img src="/static/public/image/sidebar_banners/project_logs.jpg">
                            </a>
                        </div>
                        <div class="side_bar_banners" >
                            <a href="/category/modding/">
                                <img src="/static/public/image/sidebar_banners/modding.jpg">
                            </a>
                        </div>
                        <div class="side_bar_banners" >
                            <a href="http://www.corsair.com/en-gb">
                                <img src="/static/public/image/sidebar_banners/corsair.jpg">
                            </a>
                        </div>
                        <div class="side_bar_banners" >
                            <a href="http://www.coolermaster.com/">
                                <img src="/static/public/image/sidebar_banners/coolermaster.jpg">
                            </a>
                        </div>
                    </div>
                    <div class="xtag-157">
                        <script type='text/javascript'><!--//<![CDATA[
   var m3_u = (location.protocol=='https:'?'https://serve.themediateam.net/ox/www/delivery/ajs.php':'http://serve.themediateam.net/ox/www/delivery/ajs.php');
   var m3_r = Math.floor(Math.random()*99999999999);
   if (!document.MAX_used) document.MAX_used = ',';
   document.write ("<scr"+"ipt type='text/javascript' src='"+m3_u);
   document.write ("?zoneid=157&amp;source=_blank&amp;target=_blank");
   document.write ('&amp;cb=' + m3_r);
   if (document.MAX_used != ',') document.write ("&amp;exclude=" + document.MAX_used);
   document.write (document.charset ? '&amp;charset='+document.charset : (document.characterSet ? '&amp;charset='+document.characterSet : ''));
   document.write ("&amp;loc=" + escape(window.location));
   if (document.referrer) document.write ("&amp;referer=" + escape(document.referrer));
   if (document.context) document.write ("&context=" + escape(document.context));
   if (document.mmm_fo) document.write ("&amp;mmm_fo=1");
   document.write ("'><\/scr"+"ipt>");
//]]>--></script><noscript><a href='http://serve.themediateam.net/ox/www/delivery/ck.php?n=a35f64abc&amp;cb=INSERT_RANDOM_NUMBER_HERE' target='_blank'><img src='http://serve.themediateam.net/ox/www/delivery/avw.php?zoneid=157&amp;source=_blank&amp;cb=INSERT_RANDOM_NUMBER_HERE&amp;n=a35f64ab' border='0' alt='' /></a></noscript>

                    </div>
                    <div id="shortSignup">
                        
                            <h3 class="headingBar">SUBSCRIBE TO OUR NEWSLETTER</h3>
                            <form action="/cms/emails/api/functions/short-signup/" method="post">
                                <input type='hidden' name='csrfmiddlewaretoken' value='zW6ghYDzEyyMgLTOnsJ1Ta0Dffzzfn0bYYpb3Ag9QHeOPSBWkDXuSZPQPBB4C2ry' />
                                <input id="email" type="email" name="email" placeholder="example@example.co.uk">
                                <button class="send" type="submit">
                                    <img src="/static/public/image/short_signup_icon.jpg">
                                </button>
                            </form>
                        
                        <div style="clear:both;"></div>
                    </div>
                    <div id="weekInReviews">
                        <a href="/week-in-review/">
                            <img src="/static/public/image/week.jpg" alt="">
                        </a>
                        <div class="title">
                            <h3>WEEK IN REVIEW</h3>
                        </div>
                    </div>
                    <div id="skyscrapers" class="clearfix" >
                        <div id="left_articles_container">
                            <div id="top_stories_container" class="clearfix">
                                <h3 class="headingBar">TOP STORIES</h3>
                                <div id="top_stories"></div>
                            </div>
                            <div class="clearfix" id="suggestions_container">
                                <h3 class="headingBar">SUGGESTED FOR YOU</h3>
                                <div id="side_bar_suggestions"></div>
                            </div>
                        </div>
                        <div class="xtag-165">
                            <script type='text/javascript'><!--//<![CDATA[
   var m3_u = (location.protocol=='https:'?'https://serve.themediateam.net/ox/www/delivery/ajs.php':'http://serve.themediateam.net/ox/www/delivery/ajs.php');
   var m3_r = Math.floor(Math.random()*99999999999);
   if (!document.MAX_used) document.MAX_used = ',';
   document.write ("<scr"+"ipt type='text/javascript' src='"+m3_u);
   document.write ("?zoneid=165&amp;source=_blank&amp;target=_blank");
   document.write ('&amp;cb=' + m3_r);
   if (document.MAX_used != ',') document.write ("&amp;exclude=" + document.MAX_used);
   document.write (document.charset ? '&amp;charset='+document.charset : (document.characterSet ? '&amp;charset='+document.characterSet : ''));
   document.write ("&amp;loc=" + escape(window.location));
   if (document.referrer) document.write ("&amp;referer=" + escape(document.referrer));
   if (document.context) document.write ("&context=" + escape(document.context));
   if (document.mmm_fo) document.write ("&amp;mmm_fo=1");
   document.write ("'><\/scr"+"ipt>");
//]]>--></script><noscript><a href='http://serve.themediateam.net/ox/www/delivery/ck.php?n=a35f64abc&amp;cb=INSERT_RANDOM_NUMBER_HERE' target='_blank'><img src='http://serve.themediateam.net/ox/www/delivery/avw.php?zoneid=165&amp;source=_blank&amp;cb=INSERT_RANDOM_NUMBER_HERE&amp;n=a35f64ab' border='0' alt='' /></a></noscript>

                        </div>
                    </div>
                    <div style="float:right;" ></div>
                    <div class="xtag-161">
                        <script type='text/javascript'><!--//<![CDATA[
   var m3_u = (location.protocol=='https:'?'https://serve.themediateam.net/ox/www/delivery/ajs.php':'http://serve.themediateam.net/ox/www/delivery/ajs.php');
   var m3_r = Math.floor(Math.random()*99999999999);
   if (!document.MAX_used) document.MAX_used = ',';
   document.write ("<scr"+"ipt type='text/javascript' src='"+m3_u);
   document.write ("?zoneid=161&amp;source=_blank&amp;target=_blank");
   document.write ('&amp;cb=' + m3_r);
   if (document.MAX_used != ',') document.write ("&amp;exclude=" + document.MAX_used);
   document.write (document.charset ? '&amp;charset='+document.charset : (document.characterSet ? '&amp;charset='+document.characterSet : ''));
   document.write ("&amp;loc=" + escape(window.location));
   if (document.referrer) document.write ("&amp;referer=" + escape(document.referrer));
   if (document.context) document.write ("&context=" + escape(document.context));
   if (document.mmm_fo) document.write ("&amp;mmm_fo=1");
   document.write ("'><\/scr"+"ipt>");
//]]>--></script><noscript><a href='http://serve.themediateam.net/ox/www/delivery/ck.php?n=a35f64abc&amp;cb=INSERT_RANDOM_NUMBER_HERE' target='_blank'><img src='http://serve.themediateam.net/ox/www/delivery/avw.php?zoneid=161&amp;source=_blank&amp;cb=INSERT_RANDOM_NUMBER_HERE&amp;n=a35f64ab' border='0' alt='' /></a></noscript>

                    </div>
                </div>
            </div>
        </div>
        <div class="footerContainer clearfix">
            
            <div class="xtag_container">
                <div class="xtag-169">
                    <script type='text/javascript'><!--//<![CDATA[
   var m3_u = (location.protocol=='https:'?'https://serve.themediateam.net/ox/www/delivery/ajs.php':'http://serve.themediateam.net/ox/www/delivery/ajs.php');
   var m3_r = Math.floor(Math.random()*99999999999);
   if (!document.MAX_used) document.MAX_used = ',';
   document.write ("<scr"+"ipt type='text/javascript' src='"+m3_u);
   document.write ("?zoneid=169&amp;source=_blank&amp;target=_blank");
   document.write ('&amp;cb=' + m3_r);
   if (document.MAX_used != ',') document.write ("&amp;exclude=" + document.MAX_used);
   document.write (document.charset ? '&amp;charset='+document.charset : (document.characterSet ? '&amp;charset='+document.characterSet : ''));
   document.write ("&amp;loc=" + escape(window.location));
   if (document.referrer) document.write ("&amp;referer=" + escape(document.referrer));
   if (document.context) document.write ("&context=" + escape(document.context));
   if (document.mmm_fo) document.write ("&amp;mmm_fo=1");
   document.write ("'><\/scr"+"ipt>");
//]]>--></script><noscript><a href='http://serve.themediateam.net/ox/www/delivery/ck.php?n=a35f64abc&amp;cb=INSERT_RANDOM_NUMBER_HERE' target='_blank'><img src='http://serve.themediateam.net/ox/www/delivery/avw.php?zoneid=169&amp;source=_blank&amp;cb=INSERT_RANDOM_NUMBER_HERE&amp;n=a35f64ab' border='0' alt='' /></a></noscript>

                </div>
            </div>
            
            
            <div id="footer" class="clearfix" >
                <div id="bottom_links_container" class="clearfix" >
                    <div class="col-1-8 bottom_links">
                        <h2 class="heading" >Site Links</h2>
                        <ul class="site">
                            <li>
                                <a href="/">Home</a>
                            </li>
                            <li>
                                <a href="/about/">About</a>
                            </li>
                            <li>
                                <a href="/scores/">Award Guide</a>
                            </li>
                            <li>
                                <a href="mailto:editor@bit-tech.net">Email Editor</a>
                            </li>
                            <li>
                                <a href="/terms/">Terms</a>
                            </li>
                            <li>
                                <a href="mailto:hello@bit-tech.net">Advertise</a>
                            </li>
                            <li>
                                <a href="http://www.facebook.com/bittech">Facebook Page</a>
                            </li>
                            <li>
                                <a href="#top">Back to Top</a>
                            </li>
                        </ul>
                    </div>
                        
                    <div class="col-1-4 bottom_links">
                        <h2 class="heading" >Popular Companies</h2>
                        <div class="col-6-12">
                            <ul>
                            
                                <li><a href="/press-releases/microsoft/"><span>Microsoft</span></a></li>
                                
                            
                                <li><a href="/press-releases/bit-tech/"><span>bit-tech</span></a></li>
                                
                            
                                <li><a href="/press-releases/amd/"><span>AMD</span></a></li>
                                
                            
                                <li><a href="/press-releases/intel/"><span>Intel</span></a></li>
                                
                            
                                <li><a href="/press-releases/asus/"><span>ASUS</span></a></li>
                                
                                    </ul></div><div class="col-6-12"><ul>
                                
                            
                                <li><a href="/press-releases/nvidia/"><span>Nvidia</span></a></li>
                                
                            
                                <li><a href="/press-releases/msi/"><span>MSI</span></a></li>
                                
                            
                                <li><a href="/press-releases/gigabyte/"><span>Gigabyte</span></a></li>
                                
                            
                                <li><a href="/press-releases/sony/"><span>Sony</span></a></li>
                                
                            
                                <li><a href="/press-releases/corsair/"><span>Corsair</span></a></li>
                                
                            
                            </ul>
                        </div>
                    </div>
                </div>
                <div id="bottom_info_container" >
                    <p>&copy; Copyright bit-tech</p>
                    <div id="theMediaTeamLogoContainer" style="width:90px; height:45px; float:right;">
                        <a href="http://www.themediateam.net/">
                            <img id="theMediaTeamLogo" src="/static/public/image/part_of_the_media_team.png" style="width:100%;">
                        </a>
                    </div>
                </div>
            </div>
            
            
        </div>
    </div>
</div>

<div class="opaque"></div>
<div id="login_form" style="display: none;" class="login">
    <div class="login-header">
        <div class="login-title">Login Form</div>
        <div class="login-exit"></div>
    </div>
    <div class="login-form"></div>
    <div class="login-footer"></div>
</div>

    <!-- JSON-LD -->
    <script type="text/javascript" src="/static/head/generateFromURL.js"></script>
    <!-- Tangular Template -->
    <script src="/static/external/js/Tangular.min.js"></script>
    <script type="text/template" id="sidebar_article_template">
        <div class="sidebar_article[[ categories_string ]] [[ value.section ]]" >
            <div class="image">
                <a href="[[ value.get_absolute_url ]]">
                    <img src="[[ thumbnail ]]" alt="">
                </a>
            </div>
            <div class="details">
                <div class="title">
                    <a href="[[ value.get_absolute_url ]]">
                        <h4> [[ value.title ]] </h4>
                    </a>
                </div>
            </div>
        </div>
    </script>
    <!-- SCRIPTS -->
    <script type="text/javascript">
        // desktop mobile split
        $.ajaxSetup({
            beforeSend: function(xhr, settings) {
                function getCookie(name) {
                    var cookieValue = null;
                    if (document.cookie && document.cookie != '') {
                        var cookies = document.cookie.split(';');
                        for (var i = 0; i < cookies.length; i++) {
                            var cookie = jQuery.trim(cookies[i]);
                            // Does this cookie string begin with the name we want?
                            if (cookie.substring(0, name.length + 1) == (name + '=')) {
                                cookieValue = decodeURIComponent(cookie.substring(name.length + 1));
                                break;
                            }
                        }
                    }
                    return cookieValue;
                }
                if (!(/^http:.*/.test(settings.url) || /^https:.*/.test(settings.url))) {
                    // Only send the token to relative URLs i.e. locally.
                    xhr.setRequestHeader("X-CSRFToken", getCookie('csrftoken'));
                }
            }
        });
        Ta.settings.delimiters = ["[[", "]]"];
    </script>

    <script src="/static/public/javascript/public.js"></script>
    <script async src="//serve.themediateam.net/ox/www/delivery/asyncjs.php"></script>



<script type='text/javascript'><!--//<![CDATA[
   var m3_u = (location.protocol=='https:'?'https://serve.themediateam.net/ox/www/delivery/ajs.php':'http://serve.themediateam.net/ox/www/delivery/ajs.php');
   var m3_r = Math.floor(Math.random()*99999999999);
   if (!document.MAX_used) document.MAX_used = ',';
   document.write ("<scr"+"ipt type='text/javascript' src='"+m3_u);
   document.write ("?zoneid=181&amp;source=_blank&amp;target=_blank");
   document.write ('&amp;cb=' + m3_r);
   if (document.MAX_used != ',') document.write ("&amp;exclude=" + document.MAX_used);
   document.write (document.charset ? '&amp;charset='+document.charset : (document.characterSet ? '&amp;charset='+document.characterSet : ''));
   document.write ("&amp;loc=" + escape(window.location));
   if (document.referrer) document.write ("&amp;referer=" + escape(document.referrer));
   if (document.context) document.write ("&context=" + escape(document.context));
   if (document.mmm_fo) document.write ("&amp;mmm_fo=1");
   document.write ("'><\/scr"+"ipt>");
//]]>--></script><noscript><a href='http://serve.themediateam.net/ox/www/delivery/ck.php?n=a355bc27c&amp;cb=INSERT_RANDOM_NUMBER_HERE' target='_blank'><img src='http://serve.themediateam.net/ox/www/delivery/avw.php?zoneid=181&amp;source=_blank&amp;cb=INSERT_RANDOM_NUMBER_HERE&amp;n=a355bc27' border='0' alt='' /></a></noscript>





    <script type="text/javascript">

        // handles loading multiple recaptcha
        function loadRecaptcha() {

            // through elements that include recaptcha in their id
            $('[id*="recaptcha"]').each(function(index, value){

                // calls render on recaptcha to the id of this
                grecaptcha.render($(this).attr('id'), {
                    'sitekey' : '6LcUVyQUAAAAAHLR57m4CKdmLkFXnGho75painXi',
                });
            });
        };
    </script>

    <script>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</script>
    
<script type="text/template" id="comments_template">
    <div class="comment col-1-1" id="comment_[[ id ]]" data-member="[[ user_id ]]" data-id="[[ id ]]" data-username="[[ username ]]">
        <div class="heading clearfix">
            <h4>[[ title ]]</h4>
        </div>
        <div class="comment_text_container">
            <div class="comment_text"></div>
            
            <img class="quote-icon" src="/static/public/image/icons/comment_reply.png">
        </div>
    </dv>
</script>

<script type="text/javascript">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</script>



    <!-- recaptcha -->
    <!-- <script src='https://www.google.com/recaptcha/api.js?onload=loadRecaptcha&render=explicit' async defer></script> -->
</body>
</html>

