<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
    "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html xmlns="http://www.w3.org/1999/xhtml"
      xmlns:org="http://opengraphprotocol.org/schema/"
      xmlns:fb="http://www.facebook.com/2008/fbml"
      xml:lang="en"
      lang="en">
    <head>
        <link rel="alternate" media="only screen and (max-width: 640px)" href="http://m.bit-tech.net/">
        <script type="text/javascript">
                function getUrlVars(){
                    var vars = [], hash, i, hashes;
                    hashes = window.location.href.slice(window.location.href.indexOf('?') + 1).split('&');
                    for(i = 0; i < hashes.length; i++)
                    {
                        hash = hashes[i].split('=');
                        vars.push(hash[0]);
                        vars[hash[0]] = hash[1];
                    }
                    return vars;
                }


                function getid(json){window.location = '//m.bit-tech.net/' + json[0].id + '/'; }
                    // Forms json searches and injects script into <head>

                function jsonp(quickname) {
                    jQuery.ajax({
                        url: "http://beta.bit-tech.net/rest/ajax/",
                        callback: "q",
                        dataType: "jsonp",
                        data: {
                            callback: "getid",
                            quickname: quickname.toString()
                        }
                    });
                }

                if (screen.width <= 640){
                    queryString = getUrlVars(); // holds search query dictionary
                    if(queryString["stay"] === "true" ){ // data type is a string 
                        localStorage.setItem("stay", true); // set universal cookie
                    }
                    stayInPage = (localStorage.getItem("stay") === null ? false : localStorage.getItem("stay")); // if "stay" isnt defined equal it to false
                    if(stayInPage == false){ 
                        if(window.location.href === "http://www.bit-tech.net/"){
                            window.location = "http://m.bit-tech.net/";
                        } else {
                            if(window.location.href.indexOf("bit-tech") !== -1) { // Add screen check
                                var quickname, components = window.location.href.split("/");
                                console.log(components[components.length - 2]);
                                components = components[components.length - 2];
                                jsonp(components);
                            }
                        }
                    } 
                }


            //if ((screen.width <= 640) && (window.location.href == 'http://www.bit-tech.net/')) window.location = 'http://m.bit-tech.net/';


/*
        var queryString, stayInPage;
        
        function getUrlVars() // Parses the url to get search query 
        {
            var vars = [], hash;
            var hashes = window.location.href.slice(window.location.href.indexOf('?') + 1).split('&');
            for(var i = 0; i < hashes.length; i++)
            {
                hash = hashes[i].split('=');
                vars.push(hash[0]);
                vars[hash[0]] = hash[1];
            }
            return vars;
        }
        
        // if(typeof(Storage) !== "undefined") { // IE support 
           if (screen.width <= 640){
                queryString = getUrlVars(); // holds search query dictionary
                if(queryString["stay"] === "true" ){ // data type is a string 
                    localStorage.setItem("stay", true); // set universal cookie
                }
                stayInPage = (localStorage.getItem("stay") === null ? false : localStorage.getItem("stay")); // if "stay" isnt defined equal it to false
                if(stayInPage == false){ 
                    window.location = "http://m.bit-tech.net/";
                } 
            } 
        // } 
*/


        </script>
        <meta http-equiv="Content-type" content="text/html; charset=utf-8" />
        <title>Palit GeForce GTX 1080 Ti Super JetStream Review | bit-tech.net</title>
				    <meta name="description" content="Palit GeForce GTX 1080 Ti Super JetStream Review. Palit goes all-out with this 2.5-slot monster, and it's pricey but also very fast." />
				    <meta name="keywords" content="palit,nvidia,pascal,gtx 1080 ti" />
				<link rel="search" type="application/opensearchdescription+xml" href="/opensearch.xml" title="bit-tech.net search" />
			        	    	<link rel="stylesheet" href="//images.bit-tech.net/style/article.css" type="text/css" media="all" charset="utf-8" />
	        			        <!--[if IE 6]>
	    	<link rel="stylesheet" href="//images.bit-tech.net/style/ie6/article.css" type="text/css" media="all" charset="utf-8" />
	        <![endif]-->
			        <!--[if IE 7]>
	    	<link rel="stylesheet" href="//images.bit-tech.net/style/ie7/article.css" type="text/css" media="all" charset="utf-8" />
	        <![endif]-->
			        	    	<link rel="alternate" href="/xml/hardware.rss" type="application/rss+xml" charset="utf-8" title="Hardware feed" />
	        				<link rel="stylesheet" href="//images.bit-tech.net/style/jquery.lightbox-0.5.css" type="text/css" media="screen" />
		<script src="//www.google.com/jsapi"></script>
        <script src="//code.jquery.com/jquery-1.8.3.min.js"></script>
        <!-- link rel="stylesheet" type="text/css" href="http://cdn.jsdelivr.net/jquery.slick/1.3.11/slick.css"/>
        <script type="text/javascript" src="http://cdn.jsdelivr.net/jquery.slick/1.3.11/slick.min.js></script -->
		<script type="text/javascript">
		    //<![CDATA[
			//google.load("jquery", "1.4.2");
		    google.load("prototype", "1.6");
		    google.load("swfobject", "2.2");
		    //]]>
		</script>
		<script type="text/javascript" src="//images.bit-tech.net/js/jquery.lightbox-0.5.js"></script>
		<script type="text/javascript" src="//images.bit-tech.net/js/magictabs.js"></script>
		<script type="text/javascript" src="//images.bit-tech.net/js/firefox.js"></script>
		<script type="text/javascript" src="//images.bit-tech.net/js/gafc.js"></script>
        <script type="text/javascript" src="/js/jquery.openxtag.uncompressed.js?2"></script>
		<script type="text/javascript" charset="utf-8">
		    //<![CDATA[
		    jQuery(document).ready(function() {
				if (jQuery('#article_image_click')) {
					jQuery('#article_image_click').lightBox();
				}
				new FirefoxImages();
				new Magictabs('tabBlock');

				if (jQuery.openxtag) {

					jQuery.openxtag('init', {
					    //delivery:    'http://ads.bit-tech.net/ox/www/delivery',
					    //deliverySSL: 'https://ads.bit-tech.net/ox/www/delivery'
					    delivery:    'http://serve.themediateam.net/ox/www/delivery',
					    deliverySSL: 'https://serve.themediateam.net/ox/www/delivery'
					});

					jQuery('.oxbanner').openxtag('spc', function () {
					    //console.log('loaded ad');
					});
				}
		    });
		    //]]>

		</script>

				<link rel="apple-touch-icon" href="//images.bit-tech.net/images/webclip.png" />
				<script type="text/javascript">
            //<![CDATA[
            var domain = document.domain.toLowerCase();
            var str = document.location.href.toLowerCase();
            
            var _gaq = _gaq || [];
            _gaq.push(['_setAccount', 'UA-1830151-1'],
            ['_setCustomVar', 1, 'page type', 'article', 3],
            ['_setCustomVar', 2, 'page load time', '0.045', 3],
            ['_setCustomVar', 3, 'author', 'matthew lambert', 3],
            ['_setCustomVar', 4, 'date published', '20170615', 3],
            ['_setCustomVar', 5, 'product type', 'graphics', 3],
            ['_trackPageview', str.substring((str.indexOf(domain)) + (domain.length)) + '#PT=article&PS=review']);
            _gaq.push(['_trackPageLoadTime']);
            (function() {
                var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
                ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
                var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
            })();
            //]]>
        </script>
                    <meta property="og:title" content="Palit GeForce GTX 1080 Ti Super JetStream Review"/>  
<meta property="og:type" content="article"/>  
<meta property="og:url" content="http://www.bit-tech.net/hardware/graphics/2017/06/15/palit-geforce-gtx-1080-ti-super-jetstream/1"/>  
<meta property="og:image" content="//images.bit-tech.net/content_images/2017/06/palit-geforce-gtx-1080-ti-super-jetstream/featured_double.jpg"/>  
<meta property="og:site_name" content="bit-tech"/>  
<meta property="fb:admins" content="510989727"/>
<meta property="fb:app_id" content="117087324998229"/>
            <script type="text/javascript">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</script>
    </head>
    <body class="hardware graphics">
      <a name="top" id="top"></a>
        <div class="pageContainer">
            <div id="brandHeader">
                                    <h1 class="logo"><a href="/">bit-tech.net</a></h1>
                                <div style="float: right; width: 728px; height: 90px; overflow: hidden; position: relative; top: 10px;">
                    <div class="oxbanner" data-zone-name="top_leaderboard" data-zone-id="153"></div>
                </div>
            </div>
            <div class="navContainer">
                <div id="mainNav" class="clearfix">
                    <ul>
                                                    <li>
                                <a href="/"><span>Home</span></a>
                            </li>
                            <li>
                                <a href="/news/" class="news"><span>News</span></a>
                            </li>
                            <li>
                                <a href="/reviews/" class="news"><span>Reviews</span></a>
                            </li>
                            <li class="active">
                                <a href="/hardware/" class="hardware"><span>Hardware</span></a>
                            </li>
                            <li>
                                <a href="/modding/" class="modding"><span>Modding</span></a>
                            </li>
                                                <li>
                            <a href="/gaming/" class="gaming"><span>Gaming</span></a>
                        </li>
                        <li>
                                                            <a href="/blog/" class="blog"><span>Blog</span></a>
                                                    </li>
	                    <li>
	                        <a href="http://forums.bit-tech.net" class="forum"><span>Forums</span></a>
	                    </li>

                    </ul>
                    <ul class="aux">
                        <li class="search">
                            <form action="/search" method="get" accept-charset="utf-8">
                                <div>
                                    <input type="text" name="q" value="" /><span class="button"><button type="submit">Search</button></span>
                                </div>
                            </form>
                        </li>
                    </ul>
                </div>
            </div>
            <div class="navContainer">
    <div id="subNav" class="clearfix">
        <ul>
												<li>
					    						<a href="/hardware/"><span>All</span></a>
					</li>					
																<li>
					    						<a href="/hardware/cases/"><span>Cases</span></a>
					</li>					
																<li>
					    						<a href="/hardware/cooling/"><span>Cooling</span></a>
					</li>					
																<li>
					    						<a href="/hardware/cpus/"><span>CPUs</span></a>
					</li>					
																<li class="active">
					    						<a href="/hardware/graphics/"><span>Graphics</span></a>
					</li>					
																<li>
					    						<a href="/hardware/laptops/"><span>Laptops</span></a>
					</li>					
																<li>
					    						<a href="/hardware/memory/"><span>Memory</span></a>
					</li>					
																<li>
					    						<a href="/hardware/mobile/"><span>Mobile</span></a>
					</li>					
																<li>
					    						<a href="/hardware/monitors/"><span>Monitors</span></a>
					</li>					
																<li>
					    						<a href="/hardware/motherboards/"><span>Motherboards</span></a>
					</li>					
																<li>
					    						<a href="/hardware/networking/"><span>Networking</span></a>
					</li>					
																<li>
					    						<a href="/hardware/peripherals/"><span>Peripherals</span></a>
					</li>					
																<li>
					    						<a href="/hardware/psus/"><span>PSUs</span></a>
					</li>					
																<li>
					    						<a href="/hardware/speakers/"><span>Speakers</span></a>
					</li>					
																<li>
					    						<a href="/hardware/storage/"><span>Storage</span></a>
					</li>					
							        </ul>
    </div>
</div>
			
			
            <div class="oxbanner" data-zone-name="strip_banner" data-zone-id="173" id="strip_banner"></div>
			
            <div id="bodyContainer" class="clearfix">
				
				<div class="alpha grid_18 omega clearfix">
					<div id="column_1" class="alpha grid_12">
    <div class="socialLinks">
        <div class="addthis_toolbox addthis_default_style">
            <a class="addthis_button_facebook_like" fb:like:show_faces="false"></a>
            <a class="addthis_button_tweet" tw:count="horizontal" tw:via="bittech" tw:url="http://www.bit-tech.net/hardware/graphics/2017/06/15/palit-geforce-gtx-1080-ti-super-jetstream/1" tw:text="Palit GeForce GTX 1080 Ti Super JetStream Review"></a>
        </div>
    </div>
    <h1>Palit GeForce GTX 1080 Ti Super JetStream Review</h1>
    <p class="byline">Published on 15th June 2017 by Matthew Lambert</p>   
			<div class="pageSelector">
			<select onchange="document.location.href = this.value;">
				<optgroup label="Pages">
											<option value="/hardware/graphics/2017/06/15/palit-geforce-gtx-1080-ti-super-jetstream/1" selected="selected">1 - Palit GeForce GTX 1080 Ti Super JetStream Review</option>
											<option value="/hardware/graphics/2017/06/15/palit-geforce-gtx-1080-ti-super-jetstream/2">2 - Palit GeForce GTX 1080 Ti Super JetStream Review - Test Setup</option>
											<option value="/hardware/graphics/2017/06/15/palit-geforce-gtx-1080-ti-super-jetstream/3">3 - Palit GeForce GTX 1080 Ti Super JetStream Review - 3DMark and VRMark</option>
											<option value="/hardware/graphics/2017/06/15/palit-geforce-gtx-1080-ti-super-jetstream/4">4 - Palit GeForce GTX 1080 Ti Super JetStream Review - Battlefield 1</option>
											<option value="/hardware/graphics/2017/06/15/palit-geforce-gtx-1080-ti-super-jetstream/5">5 - Palit GeForce GTX 1080 Ti Super JetStream Review - Deus Ex: Mankind Divided</option>
											<option value="/hardware/graphics/2017/06/15/palit-geforce-gtx-1080-ti-super-jetstream/6">6 - Palit GeForce GTX 1080 Ti Super JetStream Review - Fallout 4</option>
											<option value="/hardware/graphics/2017/06/15/palit-geforce-gtx-1080-ti-super-jetstream/7">7 - Palit GeForce GTX 1080 Ti Super JetStream Review - Total War: Warhammer</option>
											<option value="/hardware/graphics/2017/06/15/palit-geforce-gtx-1080-ti-super-jetstream/8">8 - Palit GeForce GTX 1080 Ti Super JetStream Review - The Witcher 3: Wild Hunt</option>
											<option value="/hardware/graphics/2017/06/15/palit-geforce-gtx-1080-ti-super-jetstream/9">9 - Palit GeForce GTX 1080 Ti Super JetStream Review - Power and Thermals</option>
											<option value="/hardware/graphics/2017/06/15/palit-geforce-gtx-1080-ti-super-jetstream/10">10 - Palit GeForce GTX 1080 Ti Super JetStream Review - Overclocking</option>
											<option value="/hardware/graphics/2017/06/15/palit-geforce-gtx-1080-ti-super-jetstream/11">11 - Palit GeForce GTX 1080 Ti Super JetStream Review - Performance Analysis and Conclusion</option>
									</optgroup>
									<optgroup label="____________________">
						<option value="/hardware/graphics/2017/06/15/palit-geforce-gtx-1080-ti-super-jetstream/comments">4 Comments</option>
					</optgroup>
							</select>
		</div>
		<div class="articleTabs">
	    <ul class="clearfix">
					        <li>
		            <a href="/hardware/graphics/2017/06/15/palit-geforce-gtx-1080-ti-super-jetstream/comments"><span>4 Comments</span></a>
		        </li>
				        <li class="active">
	            <a href="/hardware/graphics/2017/06/15/palit-geforce-gtx-1080-ti-super-jetstream/1"><span>Review</span></a>
	        </li>
	    </ul>
	</div>
    	<div class="articleCopy">
	    <!-- Article Start -->
		<h2>Palit GeForce GTX 1080 Ti Super JetStream Review</h2><b>Manufacturer: <a href="http://www.palit.com/palit/index.php?lang=en" target="_blank">Palit</a><br />
UK price (as reviewed):</b> <a href="https://www.overclockers.co.uk/palit-geforce-gtx-1080ti-super-jetstream-11264mb-gddr5x-pci-express-graphics-card-gx-03x-pl.html" target="_blank">&pound;679.99 (inc VAT)</a><br />
<b>US price (as reviewed):</b> Currently unavailable<br />
<br />
Months keep passing without consumer AMD Vega cards landing, so how exactly the red team will re-enter the premium GPU marketplace and what impact it will have remains to be seen. In the meantime, if you have a hefty wad of notes to throw at GPU hardware, the only real choice is Nvidia, and the GTX 1080 Ti is its finest offering excluding the ludicrously overpriced Titan Xp. Today we have an card from Palit – can it compete with the numerous solid versions of this GPU we've seen from other manufacturers?<br />
<br />
<div style="text-align: center; clear: both;"><a href="http://images.bit-tech.net/content_images/2017/06/palit-geforce-gtx-1080-ti-super-jetstream/1080tisj-1b.jpg" target="_blank"><img src="http://images.bit-tech.net/content_images/2017/06/palit-geforce-gtx-1080-ti-super-jetstream/1080tisj-1w.jpg" alt="Palit GeForce GTX 1080 Ti Super JetStream Review" /></a><br />
<i>Click to enlarge</i></div><br />
The 'Super' in the name of this card isn't only meaningless hyperbole, as it actually differentiates this card from the regular JetStream that uses the same cooler. The difference is that this one comes with an overclock applied, and it's in-line with what we've seen before. Out of the box, the card runs at a base clock of 1,556MHz, and this nets you a rated boost clock of 1,670MHz. This is the card's OC Mode; slightly slower clocks can be set using the built-in Gaming and Silence modes via the ThunderMaster software, but Palit appears to be pushing for maximum grunt by default, which we can't really complain about. One criticism, however, is that the memory is not overclocked and instead left at the default 11Gbps even in OC Mode.<br />
<br />
Clad in black and silver, the GTX 1080 Ti Super JetStream has a noticeably neutral colour scheme, a wise choice given that the top section is also RGB backlit. This LED section can again be controlled using the ThunderMaster software, with temperature-based effects available alongside others. <br />
<br />
<div style="text-align: center; clear: both;"><a href="http://images.bit-tech.net/content_images/2017/06/palit-geforce-gtx-1080-ti-super-jetstream/1080tisj-5b.jpg" target="_blank"><img src="http://images.bit-tech.net/content_images/2017/06/palit-geforce-gtx-1080-ti-super-jetstream/1080tisj-5w.jpg" alt="Palit GeForce GTX 1080 Ti Super JetStream Review" /></a><br />
<i>Click to enlarge</i></div><br />
Like many a third-party GTX 1080 Ti, the Super JetStream is noticeable also for its size thanks to a 2.5-slot cooler that increases the dimensions to 285mm long and 133mm tall. Such bulk demands the use of a backplate to prevent the PCB from bending or breaking under the heatsink's weight, so we're happy to see a thick brushed metal backplate here. The keen-eyed among you will have spotted a small cutout in this near the SLI fingers, and this is to give access to the dual-BIOS switch – handy if you're one for tinkering with maximum overclocks or custom BIOSes.  <br />
<br />
<div style="text-align: center; clear: both;"><a href="http://images.bit-tech.net/content_images/2017/06/palit-geforce-gtx-1080-ti-super-jetstream/1080tisj-7b.jpg" target="_blank"><img src="http://images.bit-tech.net/content_images/2017/06/palit-geforce-gtx-1080-ti-super-jetstream/1080tisj-7w.jpg" alt="Palit GeForce GTX 1080 Ti Super JetStream Review" /></a><br />
<i>Click to enlarge</i></div><br />
Nvidia dropped DVI support from the Founders Edition of this card, but Palit has reintroduced it here for a bit of extra connectivity. Otherwise, things are unchanged, so you get three DisplayPort 1.4 headers and one HDMI 2.0b. Other manufacturers have taken a more VR-friendly approach by swapping one DisplayPort for a second HDMI, so if you have a VR headset and a HDMI-based display and want both connected at once, there are better options. Also of note on the rear I/O panel is the honeycomb mesh pattern, which Palit says allows for up to 15 percent more airflow than standard designs. That said, it's questionable how much air will find its way here given that the cooler shroud is open and the vertical heatsink fins are more likely to guide air into your chassis through the top of the card or directly at your motherboard.<br />
<br />
<div style="text-align: center; clear: both;"><a href="http://images.bit-tech.net/content_images/2017/06/palit-geforce-gtx-1080-ti-super-jetstream/1080tisj-6b.jpg" target="_blank"><img src="http://images.bit-tech.net/content_images/2017/06/palit-geforce-gtx-1080-ti-super-jetstream/1080tisj-6w.jpg" alt="Palit GeForce GTX 1080 Ti Super JetStream Review" /></a><br />
<i>Click to enlarge</i></div><br />
Two supplementary eight-pin PCI-E connectors give the card a total of 375W available power, although it's only rated by Palit as needing 300W, so there should be plenty of headroom for overclocking. Sadly, the plugs are not indented, so you'll need to accommodate protruding PCI-E connectors as well as the card's already-considerable height.<br />
<br />
Dual-100mm fans are used for cooling, and they spin in opposite directions. This is a method we've seen before, and it is designed to prevent 'airflow conflicts'. We're also told that the TurboFan design of the fan blades is inspired by jet engines. A more tangible benefit is the semi-passive feature that Palit calls 0-dB Tech, which ensures that both fans will switch off once the GPU reaches a temperature of about 60°C or lower.<br />
<br />
<div style="text-align: center; clear: both;"><a href="http://images.bit-tech.net/content_images/2017/06/palit-geforce-gtx-1080-ti-super-jetstream/1080tisj-10b.jpg" target="_blank"><img src="http://images.bit-tech.net/content_images/2017/06/palit-geforce-gtx-1080-ti-super-jetstream/1080tisj-10w.jpg" alt="Palit GeForce GTX 1080 Ti Super JetStream Review" /></a><br />
<i>Click to enlarge</i></div><br />
Copious amounts of copper and aluminium are used in the GPU cooler. A copper baseplate sits on the GPU and feeds three 8mm and two 6mm heat pipes that in turn direct heat through two separate fin stacks. The copper sections are not nickel-plated, but we're not too worried as they're barely exposed or visible from the outside. The heatsinks are also fed by thermal pads and contact plates that directly cool all the memory chips and the vast majority of VRM components. <br />
<br />
<div style="text-align: center; clear: both;"><a href="http://images.bit-tech.net/content_images/2017/06/palit-geforce-gtx-1080-ti-super-jetstream/1080tisj-8b.jpg" target="_blank"><img src="http://images.bit-tech.net/content_images/2017/06/palit-geforce-gtx-1080-ti-super-jetstream/1080tisj-8w.jpg" alt="Palit GeForce GTX 1080 Ti Super JetStream Review" /></a><br />
<i>Click to enlarge</i></div><br />
Palit is using DrMOS MOSFETs here, which use a design it says has been adopted from those used with high-end server CPUs. Benefits touted are low-noise operation and an effective reduction in heat. Palit appears to be using a hefty 12+1 phase power design.<br />
<br />
<div style="text-align: center; clear: both;"><a href="http://images.bit-tech.net/content_images/2017/06/palit-geforce-gtx-1080-ti-super-jetstream/1080tisj-7b.jpg" target="_blank"><img src="http://images.bit-tech.net/content_images/2017/06/palit-geforce-gtx-1080-ti-super-jetstream/1080tisj-7w.jpg" alt="Palit GeForce GTX 1080 Ti Super JetStream Review" /></a><br />
<i>Click to enlarge</i></div><br />
One downside of this card versus others on the market is the two-year warranty. We're used to seeing three years as standard with most GPU manufacturers, and when you're spending close to &pound;700 on a GPU, these sort of things are important – Palit could do with upping its game here. <br />
<br />
<h2>Specifications</h2><ul><li><b>Graphics processor</b> Nvidia GeForce GTX 1080 Ti, 1,556MHz (1,670MHz boost)<br />
    </li><li><b>Pipeline</b> 3,584 stream processors, 224 texture units, 88 ROPs<br />
    </li><li><b>Memory</b> 11GB GDDR5X, 11Gbps effective<br />
    </li><li><b>Bandwidth</b> 484GB/sec, 352-bit interface<br />
    </li><li><b>Compatibility</b> DirectX 12, Vulcan, OpenGL 4.5<br />
    </li><li><b>Outputs/Inputs</b> 3 x DisplayPort 1.4, 1 x dual-link DVI-D, 1 x HDMI 2.0b<br />
    </li><li><b>Power connections</b> 2 x 8-pin PCI-E, top-mounted<br />
    </li><li><b>Size</b> 285mm long, 133mm tall, triple-slot<br />
    </li><li><b>Warranty</b> Two years</li></ul>        <!-- Article End -->

				
        	</div>
	<div class="pageNav">
					<div class="prev">
				<span class="button"><span><img src="//images.bit-tech.net/images/bullets/larrow-fff.gif" alt="" /> Prev</span></span>
			</div>
				
					<div class="next">
				<a href="/hardware/graphics/2017/06/15/palit-geforce-gtx-1080-ti-super-jetstream/2" title="Palit GeForce GTX 1080 Ti Super JetStream Review - Test Setup" class="button"><span>Next <img src="//images.bit-tech.net/images/bullets/rarrow-fff.gif" alt="" /></span></a>
			</div>
				
					<div class="pageSelector">
				<select onchange="document.location.href = this.value;">
					<optgroup label="Pages">
													<option value="/hardware/graphics/2017/06/15/palit-geforce-gtx-1080-ti-super-jetstream/1" selected="selected">1 - Palit GeForce GTX 1080 Ti Super JetStream Review</option>
													<option value="/hardware/graphics/2017/06/15/palit-geforce-gtx-1080-ti-super-jetstream/2">2 - Palit GeForce GTX 1080 Ti Super JetStream Review - Test Setup</option>
													<option value="/hardware/graphics/2017/06/15/palit-geforce-gtx-1080-ti-super-jetstream/3">3 - Palit GeForce GTX 1080 Ti Super JetStream Review - 3DMark and VRMark</option>
													<option value="/hardware/graphics/2017/06/15/palit-geforce-gtx-1080-ti-super-jetstream/4">4 - Palit GeForce GTX 1080 Ti Super JetStream Review - Battlefield 1</option>
													<option value="/hardware/graphics/2017/06/15/palit-geforce-gtx-1080-ti-super-jetstream/5">5 - Palit GeForce GTX 1080 Ti Super JetStream Review - Deus Ex: Mankind Divided</option>
													<option value="/hardware/graphics/2017/06/15/palit-geforce-gtx-1080-ti-super-jetstream/6">6 - Palit GeForce GTX 1080 Ti Super JetStream Review - Fallout 4</option>
													<option value="/hardware/graphics/2017/06/15/palit-geforce-gtx-1080-ti-super-jetstream/7">7 - Palit GeForce GTX 1080 Ti Super JetStream Review - Total War: Warhammer</option>
													<option value="/hardware/graphics/2017/06/15/palit-geforce-gtx-1080-ti-super-jetstream/8">8 - Palit GeForce GTX 1080 Ti Super JetStream Review - The Witcher 3: Wild Hunt</option>
													<option value="/hardware/graphics/2017/06/15/palit-geforce-gtx-1080-ti-super-jetstream/9">9 - Palit GeForce GTX 1080 Ti Super JetStream Review - Power and Thermals</option>
													<option value="/hardware/graphics/2017/06/15/palit-geforce-gtx-1080-ti-super-jetstream/10">10 - Palit GeForce GTX 1080 Ti Super JetStream Review - Overclocking</option>
													<option value="/hardware/graphics/2017/06/15/palit-geforce-gtx-1080-ti-super-jetstream/11">11 - Palit GeForce GTX 1080 Ti Super JetStream Review - Performance Analysis and Conclusion</option>
											</optgroup>
											<optgroup label="____________________">
							<option value="/hardware/graphics/2017/06/15/palit-geforce-gtx-1080-ti-super-jetstream/comments">4 Comments</option>
						</optgroup>
									</select>
			</div>
			</div>
	<div class="share clearfix">
	    <h3>Share This Review</h3>
        <div class="center">
    <!-- AddThis Button BEGIN -->
    <div class="addthis_toolbox addthis_default_style">
        <a class="addthis_button_facebook_like" fb:like:show_faces="false"></a>
        <a class="addthis_button_tweet" tw:count="horizontal" tw:via="bittech" tw:url="http://www.bit-tech.net/hardware/graphics/2017/06/15/palit-geforce-gtx-1080-ti-super-jetstream/1" tw:text="Palit GeForce GTX 1080 Ti Super JetStream Review"></a>
        <a class="addthis_button_email"></a>
        <a class="addthis_button_preferred_1"></a>
        <a class="addthis_button_preferred_2"></a>
        <a class="addthis_button_preferred_3"></a>
        <a class="addthis_button_preferred_4"></a>
        <span class="addthis_separator">|</span>
        <a class="addthis_button_compact"></a>
    </div>
    <script type="text/javascript">
    var addthis_config =
    {
        pubid: 'bittech',
        services_exclude: 'facebook,twitter,favorites',
        data_ga_property: 'UA-1830151-1'
    }
    var addthis_share =
    {
        title: 'Palit GeForce GTX 1080 Ti Super JetStream Review',
        url: 'http://www.bit-tech.net/hardware/graphics/2017/06/15/palit-geforce-gtx-1080-ti-super-jetstream/1',
        templates: {
            twitter: '{{title}} {{url}} via @bittech'
        }
    }
    </script>
    <script type="text/javascript" src="http://s7.addthis.com/js/250/addthis_widget.js#pubid=bittech"></script>
    <!-- AddThis Button END -->
</div>
	</div>

    </div>
<div id="column_2" class="grid_6 omega">
    <div style="width: 300px; margin-bottom: 10px; overflow: hidden; position: relative; right: -2px;">
        <div class="oxbanner" data-zone-name="upper_mpu" data-zone-id="157"></div>
    </div>
			<div class="widget">
	<div class="topics">
		<h2>More About...</h2>
		<ul>
							<li><a href="/tag/gtx-1080-ti"><span>gtx 1080 ti</span></a></li>
							<li><a href="/tag/nvidia"><span>nvidia</span></a></li>
							<li><a href="/company/palit"><span>Palit</span></a></li>
							<li><a href="/tag/pascal"><span>pascal</span></a></li>
					</ul>
	</div>
</div>	    <div class="alpha grid_6 omega tabbedIndexBlock">
        <div class="navContainer">
            <div id="tabBlock" class="clearfix">
                <ul>
						                    <li class="active">
	                        <a href="#related"><span>Related Articles</span></a>
	                    </li>
										                </ul>
            </div>
        </div>
        <div class="tabContent">
			            <div id="related">
                <ul>
						                    <li>
	                        <a href="/hardware/graphics/2017/05/16/msi-geforce-gtx-1080-ti-gaming-x-11g-review/1">MSI GeForce GTX 1080 Ti Gaming X 11G Review</a>
	                    </li>
						                    <li>
	                        <a href="/hardware/graphics/2017/04/13/aorus-geforce-gtx-1080-ti-review/1">Aorus GeForce GTX 1080 Ti Review</a>
	                    </li>
						                    <li>
	                        <a href="/hardware/graphics/2017/04/11/asus-geforce-gtx-1080-ti-rog-strix-review/1">Asus GeForce GTX 1080 Ti ROG Strix OC Review</a>
	                    </li>
						                    <li>
	                        <a href="/hardware/graphics/2017/03/17/inno3d-geforce-gtx-1080-ti/1">Inno3D GeForce GTX 1080 Ti iChill X3</a>
	                    </li>
						                    <li>
	                        <a href="/hardware/graphics/2017/03/09/nvidia-geforce-gtx-1080-ti-review/1">Nvidia GeForce GTX 1080 Ti Review</a>
	                    </li>
						                    <li>
	                        <a href="/news/hardware/2017/02/06/palit-gtx-1050-ti-kalmx/1">Palit announces passive GeForce GTX 1050 Ti KalmX</a>
	                    </li>
					                </ul>
            </div>
						        </div>
    </div>
	<div id="skypromo" class="alpha grid_6 omega">
    <div class="promos">
        <table>
					
			        	            		    <tr><td>
<div class="promo graphics-promo">
    	<a href="/hardware/graphics/2017/06/15/palit-geforce-gtx-1080-ti-super-jetstream/1" rel="nofollow" class="imageViewport"><img src="//images.bit-tech.net/content_images/2017/06/palit-geforce-gtx-1080-ti-super-jetstream/featured_triple.jpg" alt="Palit GeForce GTX 1080 Ti Super JetStream Review" /></a>
	<h3><a href="/hardware/graphics/2017/06/15/palit-geforce-gtx-1080-ti-super-jetstream/1">Palit GeForce GTX 1080 Ti Super JetStream Review</a></h3>
    <p class="date">15th June 2017</p>
</div>
</tr></td>
        					        	            		    <tr><td>
<div class="promo hardware-promo">
    	<a href="/hardware/2017/06/14/overclockers-uk-titan-katana-ryzen/1" rel="nofollow" class="imageViewport"><img src="//images.bit-tech.net/content_images/2017/06/overclockers-uk-titan-katana-ryzen/featured_triple.jpg" alt="Overclockers UK Titan Katana Ryzen Review" /></a>
	<h3><a href="/hardware/2017/06/14/overclockers-uk-titan-katana-ryzen/1">Overclockers UK Titan Katana Ryzen Review</a></h3>
    <p class="date">14th June 2017</p>
</div>
</tr></td>
        					        	            		    <tr><td>
<div class="promo psus-promo">
    	<a href="/hardware/psus/2017/06/13/corsair-premium-psu-cable-kit-review/1" rel="nofollow" class="imageViewport"><img src="//images.bit-tech.net/content_images/2017/06/corsair-premium-psu-cable-kit-review/featured_triple.jpg" alt="Corsair Premium PSU Cable Kit Review" /></a>
	<h3><a href="/hardware/psus/2017/06/13/corsair-premium-psu-cable-kit-review/1">Corsair Premium PSU Cable Kit Review</a></h3>
    <p class="date">13th June 2017</p>
</div>
</tr></td>
        							        </table>
    </div>
    <div style="width: 160px; margin-bottom: 10px; overflow: hidden; float: right; text-align: right;">
		<div class="oxbanner" data-zone-name="skyscraper" data-zone-id="165"></div>
    </div>
</div>



<div style="width: 300px; height: 250px; margin-bottom: 10px; overflow: hidden; position: relative; right: -2px;">
    <div class="oxbanner" data-zone-name="lower_mpu" data-zone-id="161"></div>
</div>

</div>				</div>
				
                <div class="alpha grid_15" style="margin-top: 10px">
                    <div style="width: 728px; height: 90px;">
                        <div class="oxbanner" data-zone-name="bottom_leaderboard" data-zone-id="169"></div>
                    </div>
                </div>
<script type='text/javascript'><!--//<![CDATA[
   document.MAX_ct0 = unescape('INSERT_ENCODED_CLICKURL_HERE');

   var m3_u = (location.protocol=='https:'?'https://serve.themediateam.net/ox/www/delivery/ajs.php':'http://serve.themediateam.net/ox/www/delivery/ajs.php');
   var m3_r = Math.floor(Math.random()*99999999999);
   if (!document.MAX_used) document.MAX_used = ',';
   document.write ("<scr"+"ipt type='text/javascript' src='"+m3_u);
   document.write ("?zoneid=263&amp;source=_blank&amp;target=_blank");
   document.write ('&amp;cb=' + m3_r);
   if (document.MAX_used != ',') document.write ("&amp;exclude=" + document.MAX_used);
   document.write (document.charset ? '&amp;charset='+document.charset : (document.characterSet ? '&amp;charset='+document.characterSet : ''));
   document.write ("&amp;loc=" + escape(window.location));
   if (document.referrer) document.write ("&amp;referer=" + escape(document.referrer));
   if (document.context) document.write ("&context=" + escape(document.context));
   if ((typeof(document.MAX_ct0) != 'undefined') && (document.MAX_ct0.substring(0,4) == 'http')) {
       document.write ("&amp;ct0=" + escape(document.MAX_ct0));
   }
   if (document.mmm_fo) document.write ("&amp;mmm_fo=1");
   document.write ("'><\/scr"+"ipt>");
//]]>--></script><noscript><a href='http://serve.themediateam.net/ox/www/delivery/ck.php?n=a51fcae4&amp;cb=INSERT_RANDOM_NUMBER_HERE' target='_blank'><img src='http://serve.themediateam.net/ox/www/delivery/avw.php?zoneid=263&amp;source=_blank&amp;cb=INSERT_RANDOM_NUMBER_HERE&amp;n=a51fcae4&amp;ct0=INSERT_ENCODED_CLICKURL_HERE' border='0' alt='' /></a></noscript>
<script>    
jQuery('div[id*="gpt_unit_"]').attr('style', 'clear:both; margin-top:10px; display:block; float:left; position:relative; left:-30px;');
// removing the weird text appearring at random
jQuery('div.articleCopy').html(jQuery('div.articleCopy').html().replace('GeIL has yet to confirm UK availability and pricing.', ''));
</script>
            </div>
        </div>
        <div class="footerContainer clearfix">
            <div class="logo">
                <img src="//images.bit-tech.net/images/backgrounds/footer-logo-white.png" alt="bit-tech.net" />
            </div>
            <div id="footer">
				<div class="alpha grid_4">
    <h2>
        Site Links
    </h2>
    <ul class="site">
        <li>
            <a href="/">Home</a>
        </li>
        <li>
            <a href="/about/">About</a>
        </li>
        <li>
            <a href="/scores/">Score Guide</a>
        </li>
        <li>
            <a href="mailto:editor@bit-tech.net">Email Editor</a>
        </li>
        <li>
            <a href="/terms/">Terms</a>
        </li>
        <li>
            <a href="/advertise/">Advertise</a>
        </li>
        <li>
            <a href="http://www.facebook.com/bittech">Facebook Page</a>
        </li>
        <li>
            <a href="#top">Back to Top</a>
        </li>
    </ul>
</div>

<div class="grid_6">
    &nbsp;
</div>

<div class="grid_4">
			<h2>
    Popular Topics
</h2>
    <div class="alpha grid_2">
        <ul>
        	        		<li><a href="http://www.bit-tech.net/tag/amd"><span>Amd</span></a></li>
        	        		<li><a href="http://www.bit-tech.net/tag/microsoft"><span>Microsoft</span></a></li>
        	        		<li><a href="http://www.bit-tech.net/tag/nvidia"><span>Nvidia</span></a></li>
        	        		<li><a href="http://www.bit-tech.net/tag/virtual-reality"><span>Virtual reality</span></a></li>
        	        		<li><a href="http://www.bit-tech.net/tag/ryzen"><span>Ryzen</span></a></li>
        	        </ul>
    </div>
    <div class="grid_2 omega">
        <ul>
        	        		<li><a href="http://www.bit-tech.net/tag/asus"><span>Asus</span></a></li>
        	        		<li><a href="http://www.bit-tech.net/tag/computex-2017"><span>Computex 2017</span></a></li>
        	        		<li><a href="http://www.bit-tech.net/tag/apple"><span>Apple</span></a></li>
        	        		<li><a href="http://www.bit-tech.net/tag/insecurity"><span>Insecurity</span></a></li>
        	        		<li><a href="http://www.bit-tech.net/tag/security"><span>Security</span></a></li>
        	        </ul>
    </div>
	</div>
<div class="grid_4 omega">
			<h2>
    Popular Companies
</h2>
    <div class="alpha grid_2">
        <ul>
        	        		<li><a href="http://www.bit-tech.net/company/microsoft"><span>Microsoft</span></a></li>
        	        		<li><a href="http://www.bit-tech.net/company/amd"><span>AMD</span></a></li>
        	        		<li><a href="http://www.bit-tech.net/company/intel"><span>Intel</span></a></li>
        	        		<li><a href="http://www.bit-tech.net/company/google"><span>Google</span></a></li>
        	        		<li><a href="http://www.bit-tech.net/company/asus"><span>ASUS</span></a></li>
        	        </ul>
    </div>
    <div class="grid_2 omega">
        <ul>
        	        		<li><a href="http://www.bit-tech.net/company/nvidia"><span>NVIDIA</span></a></li>
        	        		<li><a href="http://www.bit-tech.net/company/corsair"><span>Corsair</span></a></li>
        	        		<li><a href="http://www.bit-tech.net/company/ek-water-blocks"><span>EK Water Blocks</span></a></li>
        	        		<li><a href="http://www.bit-tech.net/company/cooler-master"><span>Cooler Master</span></a></li>
        	        		<li><a href="http://www.bit-tech.net/company/gigabyte"><span>Gigabyte</span></a></li>
        	        </ul>
    </div>
	</div>
<div class="alpha grid_18 omega dennis">
    <p>&copy; Copyright bit-tech</p>
</div>            </div>
        </div>
        <div id="topNavContainer" class="navContainer">
            <div id="topNav" class="clearfix">
                <ul>
                    <li>
                        <a href="http://forums.bit-tech.net/forumdisplay.php?f=42" class="forum"><span>Project Logs</span></a>
                    </li>
                    <li>
                        <a href="http://forums.bit-tech.net/forumdisplay.php?f=111" class="forum"><span>Folding @ Home</span></a>
                    </li>
                    <li>
                        <a href="/bits/" class="bits"><span>Bits</span></a>
                    </li>
                    <li style="font-size:xx-small;color:white;">newbeta</li>
                                    </ul>
                <ul class="aux">
                    <li class="rss">
                        <a href="/rss/"><span>RSS</span></a>
                    </li>
                    <li class="twitter">
                        <a href="http://www.twitter.com/bittech"><span>Twitter</span></a>
                    </li>
                    <li class="facebook">
                        <a href="https://www.facebook.com/bittech"><span>Facebook</span></a>
                    </li>
                                        <li class="newsletter">
                        <a href="/newsletter/"><span>Newsletter</span></a>
                    </li>
                </ul>
            </div>
        </div>
        
		

<div id="fb-root"></div>
<script>
  window.fbAsyncInit = function() {
    FB.init({appId: '117087324998229', status: true, cookie: true,
             xfbml: true});
  };
  (function() {
    var e = document.createElement('script'); e.async = true;
    e.src = document.location.protocol +
      '//connect.facebook.net/en_US/all.js';
    document.getElementById('fb-root').appendChild(e);
  }());
</script>	<!-- 0.045 -->

        <div class="oxbanner" data-zone-name="skin" data-zone-id="181"></div>
        <script>
        // remove the second google ad in article copy
        if (jQuery('ins.adsbygoogle').length > 1) jQuery('ins.adsbygoogle').last().detach();
        </script>
    </body>
</html>
